1. 程式人生 > >Machine Schedule(最小點覆蓋=最大匹配)

Machine Schedule(最小點覆蓋=最大匹配)

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12012 Accepted: 5118

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source


分析部分內容來自http://blog.csdn.net/hackbuteer1/article/details/7398008

分析:顯然,機器重啟次數是兩臺機器需要使用的不同模式的個數。把每個任務看成一條邊,即A機器的每個模式看成一個X節點,B機器的每個模式看成一個Y節點,任務i為邊(ai, bi)。本題即求最少的點讓每條邊至少與其中的一點關聯,即求一個點的最小覆蓋。可以證明,這個最小覆蓋就是該二分圖的最大匹配數。故二分圖匹配的模型就建好了。注意到開始時機器都處於0模式,所以如果某個任務可以在0模式下執行,則我們可以不考慮該任務,假定它已經被完成即可,也就是建圖的時候不要把與0關聯的邊加到二分圖中就可以得到正確的解。


思想:A,B兩臺機器的所有模式(除0模式)分別成為二分圖的二邊,能完成同一份工作的有邊連線。如果一個工作有一臺的0模式能完成,不需要加到二分圖中。用匈牙利演算法求出最大匹配,由最小點覆蓋=最大匹配。

#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
using namespace std;
const int maxn=105;
vector<int>map[maxn];
bool vis[maxn];
int match[maxn],n,m,k,ans;
bool dfs(int u)
{
for(int i=0;i<map[u].size();i++)
{
if(!vis[map[u][i]])
{
vis[map[u][i]]=true;
if(match[map[u][i]]==-1||dfs(match[map[u][i]]))
{
match[map[u][i]]=u;
return true;
}
}
}
return false;
}
void hangry()
{
memset(match,-1,sizeof(match));
ans=0;
for(int i=1;i<n;i++)
{
memset(vis,false,sizeof(vis));
if(dfs(i))
ans++;
}
}
int main()
{
int i,x,y;
while(scanf("%d",&n)==1)
{
if(n==0)
break;
scanf("%d%d",&m,&k);
for(i=1;i<=maxn;i++)
map[i].clear();
while(k--)
{
scanf("%d%d%d",&i,&x,&y);
if(x==0||y==0)
continue;
else
{
map[x].push_back(y);
}
}
hangry();
printf("%d\n",ans);
}
return 0;
}