1. 程式人生 > >Romantic hd 2669

Romantic hd 2669

Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.



Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)



Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.



Sample Input
77 51
10 44
34 79


Sample Output
2 -3
sorry

7 -3

#include<cstdio>
#include<cmath>
long long e_gcd(long long a,long long b,long long &x,long long &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		return a;
	}
	long long ans=e_gcd(b,a%b,x,y);
	long long temp=x;
	x=y;
	y=temp-a/b*y;
	return ans;
}
long long cal(long long a,long long b,long long c)
{
	long long x,y;
	long long gcd=e_gcd(a,b,x,y);
	if(c%gcd!=0)	return -1;
	x*=c/gcd;
	b/=gcd;
	if(b<0)	b=-b;
	long long ans=x%b;
	if(ans<=0)	ans+=b;
	return ans;
}
int main()
{
	long long a,b;
	while(scanf("%I64d%I64d",&a,&b)!=EOF)
	{
		long long ans=cal(a,b,1);
		if(ans==-1)	printf("sorry\n");
		else	printf("%I64d %I64d\n",ans,(1-ans*a)/b);
	}
	return 0;
}