1. 程式人生 > >sincerit 2669 Romantic

sincerit 2669 Romantic

2669 Romantic Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 10370 Accepted Submission(s): 4427

Problem Description The Sky is Sprite. The Birds is Fly in the Sky. The Wind is Wonderful. Blew Throw the Trees Trees are Shaking, Leaves are Falling. Lovers Walk passing, and so are You. …Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy Xa + Yb = 1. If no such answer print “sorry” instead.

Input The input contains multiple test cases. Each case two nonnegative integer a,b (0<a, b<=2^31) Output output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead. Sample Input 77 51 10 44 34 79 Sample Output 2 -3 sorry 7 -3

ax + by = gcd(a,b) 當gcd(a,b) == 1時 想,即為答案 當gcd(a,b) != 1時, 先當成1計算最後結果x,y同乘與gcd(a,b) 當要求x大於0時, while (x <=0 ) x += b, y -= a;

#include <iostream>
using namespace std;
typedef long long ll;
// ax + by = 1;
ll extgcd(ll a, ll b, ll &x, ll &y) {
  ll temp;
  if (b == 0) {
    x = 1;
    y =
0; return a; } else { temp = extgcd(b, a%b, y, x); y -= (a/b) * x; } return temp; } int main() { ll n, m; while (cin >> n >> m) { ll x, y; ll k = extgcd(n, m, x, y); if (k != 1) cout << "sorry\n"; else { // a(x+b) + b(y-a) == ab + ax + by - ab = 1 while (x <= 0) { x += m; y -= n; } cout << x << " " << y << "\n"; } } return 0; }