1. 程式人生 > >杭電 2852 樹狀陣列+二分

杭電 2852 樹狀陣列+二分

題目:

KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1314    Accepted Submission(s): 565


Problem Description For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?

Input Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.

Output For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
Sample Input 5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
Sample Output No Elment! 6 Not Find! 2 2 4 Not Find! ac程式碼:
//樹狀陣列的應用。題目裡給了3中操作,插入,刪除和查詢
//插入和刪除可以歸結為一類操作,用樹狀陣列插入時,每個
//元素的值增加1即可,刪除時,每個元素的值減1即可。查詢
//操作時,用到了樹狀陣列的查詢和二分的方法。設比a大的第
//k大的元素,則設total=num[a+1]+...+num[M],若total比k大,
//則折半,時間複雜度為log(n);
#include <iostream>
#include <cstdio>
using namespace std;
const int M=100002;
int num[M];
int lowbit(int x){
  return x&(-x);
}//lowbit
void add(int pos,int value){
	while(pos<M){
	  num[pos]+=value;
	 // printf("num[%d]=%d\n",pos,num[pos]);
	  pos+=lowbit(pos);
	}
}//add
int sum(int x){
  int total=0;
  while(x>0){
    total+=num[x];
	x-=lowbit(x);
  }
 // printf("total=%d\n",total);
  return total;
}//sum
int find(int x,int y){
  int newsum=sum(x);
  int leftside=x+1;//最左為x+1
  int rightside=M-1;//最右為M-1
  int ans=M;
  int total=0;
  while(leftside<=rightside){
	int pos=(leftside+rightside)>>1;
    total=sum(pos)-newsum;
	if(total>=y){
	  rightside=pos-1;
	  if(pos<ans)
		  ans=pos;
	}//if
	else
		leftside=pos+1;
  }//while
  return ans;
}//find
int main(){
	freopen("1.txt","r",stdin);
	int n;
	while(~scanf("%d",&n)){
		int type;
		int x,y;
		for(int i=0;i<M;++i)
		   num[i]=0;
		while(n--){
		  scanf("%d",&type);
		  if(type==0)
		  {
		    scanf("%d",&x);
			add(x,1);
		  }//if
		  else if(type==1){
		    scanf("%d",&x);
			if(sum(x)-sum(x-1)==0)
				printf("No Elment!\n");
			else
				add(x,-1);
		  }//else if
		  else{
		    scanf("%d%d",&x,&y);
			int count=find(x,y);
			if(count==M)
				printf("Not Find!\n");
			else
				printf("%d\n",count);
		  }//else
		}//while
	}//while
  return 0;
}//main