1. 程式人生 > >杭電ACM2001題------java語言

杭電ACM2001題------java語言

計算兩點間的距離

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 181355    Accepted Submission(s): 63727


Problem Description 輸入兩點座標(X1,Y1),(X2,Y2),計算並輸出兩點間的距離。
Input 輸入資料有多組,每組佔一行,由4個實陣列成,分別表示x1,y1,x2,y2,資料之間用空格隔開。
Output 對於每組輸入資料,輸出一行,結果保留兩位小數。
Sample Input 0 0 0 1 0 1 1 0
Sample Output 1.00

1.41

import java.util.*;
class Main{
    public static void main (String args[]){
    Scanner sc = new Scanner(System.in);
    while(sc.hasNext()){
        double x1 = sc.nextDouble();
        double y1 = sc.nextDouble();
        double x2 = sc.nextDouble();
        double y2 = sc.nextDouble();
        double p=(x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
        System.out.printf("%.2f\r\n",Math.sqrt(p));//Math.sprt();開方
        }
    }
}