1147 Heaps(30 分)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int
Output Specification:
For each given tree, print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
題意:
給一個樹的層序遍歷,判斷它是不是堆,是大頂堆還是小頂堆。輸出這個樹的後序遍歷
思路:
解決的問題分幾塊
①判斷是否是大根堆或小根堆,先看層序遍歷前兩個數字大小,決定接下來判斷是大根還是小根,又發現不一樣的則不是堆。
②層序遍歷轉後序遍歷,根據數字下標便可。
C++:
#include "cstdio"
#include "vector"
#include "iostream"
using namespace std;
int n,m;
vector<int> v;
void postOrder(int index){
if (index>=m)return;
postOrder(index*2+1);
postOrder(index*2+2);
printf("%d%s",v[index],index==0?"\n":" ");
}
int main(){
cin>>n>>m;
v.resize(m);
for (int i=0;i<n;i++)
{
for (int j=0;j<m;j++)
{
cin>>v[j];
}
int flag=v[0]>v[1]?1:-1;//1代表大根堆 -1代表小跟堆
for (int j=0;j<=(m-1)/2;j++)
{
int left=j*2+1,right=j*2+2;
if (flag==1&&(v[j]<v[left]||(right<m&&v[j]<v[right])))flag=0;
if (flag==-1&&(v[j]>v[left]||(right<m&&v[j]>v[right])))flag=0;
}
if (flag==0)printf("Not Heap\n");
else
printf("%s\n",flag==1?"Max Heap":"Min Heap");
postOrder(0);
}
return 0;
}