1. 程式人生 > >HDU 5935 Car 【模擬】 (2016年中國大學生程式設計競賽(杭州))

HDU 5935 Car 【模擬】 (2016年中國大學生程式設計競賽(杭州))

Car

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25    Accepted Submission(s): 12

Problem Description Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record N
 positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at 0.

Now they want to know the minimum time that Ruins used to pass the last position.
Input First line contains an integer T, which indicates the number of test cases.

Every test case begins with an integers N
, which is the number of the recorded positions.

The second line contains N numbers a1a2aN, indicating the recorded positions.

Limits
1T100
1N105
0<ai109
ai<ai+1
Output For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum time.
Sample Input 1 3 6 11 21
Sample Output Case #1: 4
Source
Recommend liuyiding   |   We have carefully selected several similar problems for you:  
5943
 5942 5941 5940 5939 

題目連結:

題目大意:

  一輛車,從t=0開始走,速度只能遞增,可為小數。警察在t為整數的時候記錄了N個車的位置(整數),問到達最後一個位置時這輛車總共開了多久。

題目思路:

  【模擬】

  首先可以知道答案必為整數,並且每一段距離都是勻速的。

  從後往前看,最後一段距離X[N]-X[N-1]必然花了t=1s的時間(沒有約束條件,速度可以任意加),V=X[N]-X[N-1]。

  那麼在它之前的距離X‘,只要滿足速度V‘<V即可,那麼把X’均分成t段,每段時間為1,行走距離V‘,只要V’*t恰好>X‘即可。

  這樣往前遞推,每一段的速度都不能超過前面。

  注意精度問題。


//
//by coolxxx
//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<bitset>
#include<memory.h>
#include<time.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
//#include<stdbool.h>
#include<math.h>
#pragma comment(linker,"/STACK:1024000000,1024000000")
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
#define abs(a) ((a)>0?(a):(-(a)))
#define lowbit(a) (a&(-a))
#define sqr(a) ((a)*(a))
#define swap(a,b) ((a)^=(b),(b)^=(a),(a)^=(b))
#define mem(a,b) memset(a,b,sizeof(a))
#define eps (1e-8)
#define J 10000
#define mod 1000000007
#define MAX 0x7f7f7f7f
#define PI 3.14159265358979323
#define N 100004
using namespace std;
typedef long long LL;
double anss;
LL aans;
int cas,cass;
int n,m,lll,ans;
int a[N];
double v;
int main()
{
	#ifndef ONLINE_JUDGEW
//	freopen("1.txt","r",stdin);
//	freopen("2.txt","w",stdout);
	#endif
	int i,j,k;
	int x,y,z;
//	init();
//	for(scanf("%d",&cass);cass;cass--)
	for(scanf("%d",&cas),cass=1;cass<=cas;cass++)
//	while(~scanf("%s",s))
//	while(~scanf("%d%d",&n,&m))
	{
		ans=1;
		printf("Case #%d: ",cass);
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		v=a[n]-a[n-1];
		for(i=n-1;i;i--)
		{
			x=a[i]-a[i-1];
			if(x<=v+eps)
			{
				v=x;
				ans++;
			}
			else
			{
				ans+=(int(double(x-eps)/v)+1);
				v=(double(x)/(int(double(x-eps)/v)+1));
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}
/*
//

//
*/