1. 程式人生 > >迷宮問題(廣搜 bfs)

迷宮問題(廣搜 bfs)

迷宮問題

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 63   Accepted Submission(s) : 38
Problem Description 定義一個二維陣列:
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一個迷宮,其中的1表示牆壁,0表示可以走的路,只能橫著走或豎著走,不能斜著走,要求程式設計序找出從左上角到右下角的最短路線。 Input 一個5 × 5的二維陣列,表示一個迷宮。資料保證有唯一解。 Output 左上角到右下角的最短路徑,格式如樣例所示。 Sample Input 0 1 0 0 0 0 1 0 1 0 0 0 0 0 0 0 1 1 1 0 0 0 0 1 0 Sample Output (0, 0) (1, 0) (2, 0) (2, 1) (2, 2) (2, 3) (2, 4) (3, 4) (4, 4)

廣搜bfs,需要記錄路徑,每逢搜尋膝蓋疼TAT

解法一:

#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
using namespace std;
struct Node
{
	int x, y, step, prex, prey;
	friend bool operator < (Node a, Node b)
	{
		return a.step > b.step; 
	}
};
Node path[5][5];//記錄第一次到座標x, y 的節點 
int map[5][5];//圖 
int vis[5][5];//該點是否查詢過 
int move[4][2] = {0,1, 0,-1, 1,0, -1,0};
bool judge(int x, int y)
{
	return x >= 0 && x < 5 && y >= 0 && y < 5 && !map[x][y] && !vis[x][y];
}
void findpath(int ex, int ey)
{
	stack<Node> rec;//用棧記錄 
	Node now;
	now = path[ex][ey];//從最後節點開始 向前找 
	rec.push(now);
	while(1)
	{
		now = path[now.prex][now.prey];
		rec.push(now);
		if(now.x == 0 && now.y == 0)
		break;
	}
	while(!rec.empty())
	{
		now = rec.top();
		rec.pop(); 
		printf("(%d, %d)\n", now.x, now.y); 
	}
} 
void BFS()
{
	priority_queue<Node> Q;
	Node now, next;
	now.x = 0;
	now.y = 0;
	now.step = 0;
	Q.push(now);
	while(!Q.empty())
	{
		now = Q.top();
		Q.pop();
		if(now.x == 4 && now.y == 4) 
		{
			path[now.x][now.y] = now;//記錄 
			break;
		}
		for(int k = 0; k < 4; k++)
		{
			next.x = now.x + move[k][0];
			next.y = now.y + move[k][1];
			next.step = now.step + 1;
			if(judge(next.x, next.y))
			{
				vis[next.x][next.y] = 1;
				next.prex = now.x;//記錄前一路徑 
				next.prey = now.y;
				Q.push(next);
				path[next.x][next.y] = next;//記錄前一節點 
			} 
		} 
    }
    findpath(4, 4);
}
int main()
{
	for(int i = 0; i < 5; i++)
	{
		for(int j = 0; j < 5; j++)
		scanf("%d", &map[i][j]);
	}
	memset(vis, 0, sizeof(vis));
	BFS();
	return 0;
}

另外一種是自己模擬了佇列,但不刪除隊頭元素,所以很容易輸出記錄的路徑(貌似不能保證最優):

#include<stdio.h>
#include<iostream>
using namespace std;
int map[5][5];
int dx[4]={1,0,0,-1};
int dy[4]={0,1,-1,0};
int front = 0,rear = 1;
struct ndoe
{
	int x,y,pre;
} q[100];
void print(int i)
{
	if(q[i].pre!=-1)
	{
		print(q[i].pre);
		printf("(%d, %d)\n",q[i].x,q[i].y);
	}
}
void bfs(int x1,int y1)
{
	q[front].x = x1;
	q[front].y = y1;
	q[front].pre = -1;
	while(front < rear)//當佇列不空
	{
		for(int i=0;i<4;i++)//搜尋可達的路徑
		{
			int a=dx[i]+q[front].x;
			int b=dy[i]+q[front].y;
			if(a<0||a>=5||b<0||b>=5||map[a][b])//是否在迷宮內,是否可行
				continue;
			else
			{
				map[a][b] = 1;//走過的路做標記
				q[rear].x = a;
				q[rear].y = b;
				q[rear].pre = front;
				rear++;//入隊
			}
			if( a == 4&&b == 4)
			print(front);
		}
		front++;//出隊
	}
}
int main()
{
	int i,j,k;
	for(i = 0;i < 5;i++)
	for(j = 0;j < 5;j++)
		scanf("%d",&map[i][j]);
	printf("(0, 0)");
	printf("\n");	
	bfs(0,0);
	printf("(4, 4)");
	printf("\n");	
	return 0;
}