1. 程式人生 > >排名 1236

排名 1236

Problem Description

今天的上機考試雖然有實時的Ranklist,但上面的排名只是根據完成的題數排序,沒有考慮
每題的分值,所以並不是最後的排名。給定錄取分數線,請你寫程式找出最後通過分數線的
考生,並將他們的成績按降序列印。

Input

測試輸入包含若干場考試的資訊。每場考試資訊的第1行給出考生人數N ( 0 < N
< 1000 )、考題數M ( 0 < M < = 10 )、分數線(正整數)G;第2行排序給出第1題至第M題的正整數分值;以下N行,每行給出一
名考生的准考證號(長度不超過20的字串)、該生解決的題目總數m、以及這m道題的題號
(題目號由1到M)。
當讀入的考生人數為0時,輸入結束,該場考試不予處理。

Output

對每場考試,首先在第1行輸出不低於分數線的考生人數n,隨後n行按分數從高
到低輸出上線考生的考號與分數,其間用1空格分隔。若有多名考生分數相同,則按他們考
號的升序輸出。

Sample Input

4 5 25

10 10 12 13 15

CS004 3 5 1 3

CS003 5 2 4 1 3 5

CS002 2 1 2

CS001 3 2 3 5

1 2 40

10 30

CS001 1 2

2 3 20

10 10 10

CS000000000000000001 0

CS000000000000000002 2 1 2

0

Sample Output

3

CS003 60

CS001 37

CS004 37

0

1

CS000000000000000002 20

Hint

Huge input, scanf is recommended.

#include <iostream>
#include <string>
#include <cstring>
#include <set>

struct student
{
    std::string strID;
    int nScore;
    student() : nScore(0)
    {
        strID.clear();
    }
    bool operator>(const student &rhd) const
    {
        if(nScore == rhd.nScore)
        {
            return strID < rhd.strID;
        }
        else
        {
            return nScore > rhd.nScore;
        }
    }
    bool operator==(const student &rhd) const
    {
        return strID == rhd.strID;
    }
};

int main(int argc, const char *argv[])
{
    int nStudent = 0, nObject = 0, nScore = 0;
    while(std::cin >> nStudent && nStudent != 0 && std::cin >> nObject >> nScore)
    {
        std::set<student, std::greater<student> > setStudent;
        int *pScore = new int[nObject];
        for(int i = 0;i < nObject;++ i)
        {
            std::cin >> pScore[i];
        }
        for(int i = 0;i < nStudent;++ i)
        {
            student stuTemp;
            int nNumber;
            std::cin >> stuTemp.strID >> nNumber;
            while(nNumber --)
            {
                int n;
                std::cin >> n;
                stuTemp.nScore += pScore[n - 1];
            }
            if(stuTemp.nScore >= nScore)
            {
                setStudent.insert(stuTemp);
            }
        }
        std::cout << setStudent.size() << std::endl;
        std::set<student, std::greater<student> >::iterator iter;
        for(iter = setStudent.begin();iter != setStudent.end();++ iter)
        {
            std::cout << iter->strID << " " << iter->nScore << std::endl;
        }
        delete []pScore;
    }

    //system("pause");
    return 0;
}