1. 程式人生 > >杭電 HDU 1236 排名

杭電 HDU 1236 排名

排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17116    Accepted Submission(s): 6167


Problem Description 今天的上機考試雖然有實時的Ranklist,但上面的排名只是根據完成的題數排序,沒有考慮
每題的分值,所以並不是最後的排名。給定錄取分數線,請你寫程式找出最後通過分數線的
考生,並將他們的成績按降序列印。

Input 測試輸入包含若干場考試的資訊。每場考試資訊的第1行給出考生人數N ( 0 < N
< 1000 )、考題數M ( 0 < M < = 10 )、分數線(正整數)G;第2行排序給出第1題至第M題的正整數分值;以下N行,每行給出一
名考生的准考證號(長度不超過20的字串)、該生解決的題目總數m、以及這m道題的題號
(題目號由1到M)。
當讀入的考生人數為0時,輸入結束,該場考試不予處理。

Output 對每場考試,首先在第1行輸出不低於分數線的考生人數n,隨後n行按分數從高
到低輸出上線考生的考號與分數,其間用1空格分隔。若有多名考生分數相同,則按他們考
號的升序輸出。

Sample Input 4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
Sample Output 3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20 Hint
Huge input, scanf is recommended. 挺簡單 ,按照他說的來 就ok。注意某些資料型別AC Code:
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
struct person
{
	string str;
	int n;
	int t[11];//儲存考試題號
	double score;
}per[1001];

bool cmp(person T,person A)
{
	if(T.score!=A.score)
		return T.score>A.score;
	else
		return T.str<A.str;
}
	
int main()
{
	int N,st;//st表示解決的題目總數
	double scline;//分數線
	while(cin>>N>>st>>scline,N)
	{
		for(int p=0;p<N;p++)//每次測試重置score
			per[p].score=0;
		double *persc=new double[10001];//記錄每道題目的分值
	for(int i=1;i<=st;i++)
	{
		cin>>persc[i];
	}
	for(int j=0;j<N;j++)
	{
		cin>>per[j].str>>per[j].n;
	     for(int k=1;k<=per[j].n;k++)//表示輸入結局的題號
			 cin>>per[j].t[k];
		 for(int q=1;q<=per[j].n;q++)

			 per[j].score+=persc[per[j].t[q]];
	}
	sort(per,per+N,cmp);
	int *temp=new int [1001];int x=0;//記錄滿足條件的結構物件
	for(int t=0;t<N;t++)
	{
		if(per[t].score>=scline)
			temp[x++]=t;
	}
	
	cout<<x<<endl;
	for(int g=0;g<x;g++)
	{
      	cout<<per[temp[g]].str<<" "<<per[temp[g]].score<<endl;
			
		}
	}
	return 0;
}