1. 程式人生 > >poj-2253(最小瓶頸路問題)

poj-2253(最小瓶頸路問題)

mini opera sunscreen script queue med sar execute scrip

題目鏈接

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

可用二分法與BFS法解決,但有更好的算法。先求出最小生成樹,起點和終點在樹上的唯一路徑就是我們所要找的路徑。需要註意的是這道題只用求最短的那條邊,所以如果用kruskal算法不用將最小生成樹求出來,只要起點和終點連通即可。

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>

using namespace std;

struct aa{
    int x;
    int y;
    aa(int x1,int y1):x(x1),y(y1){}
};

struct bb{
    int a;
    int b;
    int c;
    bb(int a1,int b1,int c1):a(a1),b(b1),c(c1){}
    bool operator < (const bb &rhs)const{
        return c > rhs.c;
    }
};

vector<aa>s;
priority_queue<bb>z;
int p[251];

int find_z(int x){
    return p[x]==x?x:p[x]=find_z(p[x]);
}

int main(){
    int n;
    int yy=0;
    while(~scanf("%d",&n)){
        if(n==0)break;
        yy++;
        s.clear();
        while(!z.empty())z.pop();

        for(int i=0,q,w;i<n;i++){
            scanf("%d%d",&q,&w);
            s.push_back(aa(q,w));
        }

        for(int i=0,o;i<n;i++){
            for(int j=0;j<n;j++){
                o=(s[i].x-s[j].x)*(s[i].x-s[j].x)+(s[i].y-s[j].y)*(s[i].y-s[j].y);
                z.push(bb(i,j,o));
            }
        }

        for(int i=0;i<n;i++)p[i]=i;
        while(!z.empty()){
            bb zz=z.top(); z.pop();
            if( find_z(zz.a) != find_z(zz.b) ){
                p[find_z(zz.a)]=find_z(zz.b);
            }
            if(find_z(0)==find_z(1)){
                printf("Scenario #%d\n",yy);
                double sss=(double)zz.c;
                printf("Frog Distance = %.3lf\n\n",sqrt(sss));
                break;
            }
        }
    }
    return 0;
}

poj-2253(最小瓶頸路問題)