1. 程式人生 > >單調棧(POJ2559)

單調棧(POJ2559)

name have integer align set base namespace .org ase

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
技術分享圖片

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1
. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000
題意圖給的很明顯了,代碼如下
#include<iostream>
#include<cstring>
using namespace std;
int a[100005],s[100005],w[100005];
int main()
{
    int n,x;
    long long ans;
while(1)
{
    int p=0;
    ans=0;
    memset(a,0,sizeof(a));
    memset(w,0,sizeof(a));
    memset(s,0,sizeof(s));
    cin>>n;
    if(n==0)
    break;
    for(int i=1;i<=n;i++)
    cin>>a[i];
    a[n+1]=p;
    for(int i=1;i<=n+1;i++)
    {
        if(a[i]>s[p])
    {
            s[++p]=a[i];
        w[p]=1;
    }
    else
    {
        int width=0;
        while(s[p]>a[i])
        {
            width=width+w[p];
            ans=max(ans,(long long )width*s[p]);
            p--;
        }
        s[++p]=a[i],w[p]=width+1;
    }
    }
    cout<<ans<<endl;
}
 } 

有時間再補是STL的(其實本來寫的是STL,結果發現過不了樣例

單調棧(POJ2559)