1. 程式人生 > 實用技巧 >HDU 1004 Let the Balloon Rise

HDU 1004 Let the Balloon Rise

HDU 1004

Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

#include<stdio.h>
#include<string.h>
int main(){
	int i,j,n,max,index;
	char color[1005][15];
	//int num[1005]={0}; 要分清全域性變數和過程變數,一開始我寫在這裡,出錯了,因為它是全域性變數,在下面的++操作中,不會被重新整理,重新初始化為0,導致WA
	while(scanf("%d",&n)&&n){
		int num[1005]={0};//寫在這裡就解決了
		max=0;index=0;//記得初始化引數,老是忘記
		for(i=0;i<n;i++){
			scanf("%s",&color[i]);
			for(j=0;j<=i;j++){
				if(strcmp(color[i],color[j])==0){
					num[j]++;
					if(num[j]>max){
						max=num[j];
						index=j;
					}
					break;
				}
			}
		}
		printf("%s\n",color[index]);
	}
}

Note:

私以為我寫的更加簡潔一點,在輸入的時候就已經遍歷了