1. 程式人生 > 實用技巧 >【線段樹】poj 2828 Buy Tickets

【線段樹】poj 2828 Buy Tickets

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 28643 Accepted: 13533

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi

and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly--2006.05.28, Zhu, Zeyuan 題意:第i個人的編號為vi,要插隊在pi個人的後面,問最後的隊伍的編號 首先很容易想到倒著操作 對於一個要插到pi後的人,它前面一定要有pi個空位,也就是在這個人之前有pi個站的位置 所以我們用線段樹來維護區間空位個數,時間複雜度O(N*logN) 程式碼
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=2e5+5;
int n;
int p[maxn],v[maxn],a[maxn];
struct point
{
    int l,r,pos;
}tr[maxn<<2];
void pushup(int now)
{
    tr[now].pos=tr[now<<1].pos+tr[now<<1|1].pos;
}
void build(int now,int l,int r)
{
    tr[now].l=l; tr[now].r=r;
    if(l==r)
    {
        tr[now].pos=1;
        return;
    }
    int mid=l+r>>1;
    build(now<<1,l,mid);
    build(now<<1|1,mid+1,r);
    pushup(now);
}
int query(int now,int x)
{
    if(tr[now].l==tr[now].r)
    {
        tr[now].pos=0;
        return tr[now].l;
    }
    int res;
    if(x<=tr[now<<1].pos) res=query(now<<1,x);
    else res=query(now<<1|1,x-tr[now<<1].pos);
    pushup(now);
    return res;
}
int main()
{
    freopen("a.in","r",stdin);
    freopen("a.out","w",stdout);
    while(scanf("%d",&n)!=EOF)
    {
        build(1,1,n);
        for(int i=1;i<=n;i++) scanf("%d%d",&p[i],&v[i]);
        for(int i=n;i>=1;i--)
        { 
            int t=query(1,p[i]+1);
            a[t]=v[i];
        } 
        for(int i=1;i<=n;i++)
            printf("%d ",a[i]);
        printf("\n");
    }
    return 0;    
}