1. 程式人生 > 其它 >How Many Answers Are Wrong(HDU 3038 帶權並查集判錯)

How Many Answers Are Wrong(HDU 3038 帶權並查集判錯)

技術標籤:並查集杭電oj演算法

How Many Answers Are Wrong

TT and FF are … friends. Uh… very very good friends -________-b
FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).
Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

BoringBoring~a very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.
The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.
However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.
What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.
But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.
Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.
You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

猛然一看這題跟並查集貌似沒有什麼毛線關係啊,不過仔細觀察可以發現既然要判斷矛盾就肯定知道與以前的資料有衝突的地方,因為沒有說這個數列是不是正整數所以衝突的方式只有一種,比如先說了連個區間

1-10 10

1-5 2

6-10 5

跟明顯第三句話就可以看出來問題了,第二個加第三個跟第一個不相等,但是他們表述的區間都是相同的,所以產生矛盾,不過這種矛盾應該怎麼判斷呢,我們可以以它的端點為點建立一個集合,他們的根就是能到達的最左端,如果都有相同的最左端那麼就可以判斷一下是否有矛盾產生。
在這裡插入圖片描述
比如上面這個圖, 我們已經知道了AB的長度和AC的長度,如果下面再來一個CB,我們就可以知道C的最左端是A,B的最左端也是A,那麼就可以判斷一個AC+CB的長度是不是等於AB的長度就可以了。。。。

如果最左端不相同的話合併的時候要先比較一下最左端是哪個

對於A~B之間的和是S,其實可以理解成B比A-1大S;
敲程式碼:

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=200001;
int f[maxn];
int val[maxn];
int find(int t)
{
    if(f[t]==-1)return t;
    int ans=find(f[t]);
            val[t]+=val[f[t]];
    return f[t]=ans;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(f,-1,sizeof(f));
        memset(val,0,sizeof(val));
        int ans=0;
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            a=a-1;
            int t1=find(a);
            int t2=find(b);
            if(t1!=t2)
            {
                f[t2]=t1;
                val[t2]=val[a]-val[b]+c;
            }
            else
            {
                if(val[b]-val[a]!=c)
                    ans++;

            }

        }
        printf("%d\n",ans);

    }

    return 0;
}