1. 程式人生 > 其它 >How Many Answers Are Wrong(帶權並查集)

How Many Answers Are Wrong(帶權並查集)

技術標籤:c++

帶權並查集:
TT and FF are … friends. Uh… very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

在這裡插入圖片描述

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

BoringBoringa very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output
A single line with a integer denotes how many answers are wrong.

Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output
1
解析:
解釋一下為什麼要將a–,這個其實很關鍵的。比如現在又 1 2 3 4 5 五個數那麼如果不將a減1的話會得到sum[1]=15;sum[2]=14;…sum[5]=5;
那麼之後要是求1到5的總和的話我們是採用相減的辦法即:sum[5]-sum[1]=10;所以這個答案顯然不對。我們就採取a–的辦法得到sum[0]=15;…sum[4]=5;sum[5]=0;就可以得到正確的答案了。
AC:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxx=1e6+10;
int sum[maxx],bcj[maxx];
int find_set(int z)
{
    if(z!=bcj[z])
    {
        int t=bcj[z];
        bcj[z]=find_set(bcj[z]);//路徑壓縮
        sum[z]+=sum[t];//將每個根的權重都相加,直到加到最後的根。
    }
    return bcj[z];
}
void union_set(int x,int y,int z)
{
    int dx=find_set(x);
    int dy=find_set(y);
    if(dx!=dy)
    {
        bcj[dx]=dy;
        sum[dx]=z+sum[y]-sum[x];//這個式子畫個圖很容易看出。
    }
}
void init()
{
    for(int i=0;i<=maxx;i++)
    {
        sum[i]=0;
        bcj[i]=i;
    }
}
int main()
{
    int n,m,a,b,c;
    while(cin >> n >> m)
    {
        init();
        int ans=0;
        while(m--)
        {
            cin >> a >> b >> c;
            a--;//具體看上邊解析
            if(find_set(a)==find_set(b))//如果兩個數有相同的根。
            {
                if(sum[a]-sum[b]!=c)
                    ans++;
            }
            else
            {
                 union_set(a,b,c);
            }
        }
        cout << ans << endl;
    }
    return 0;
}

第一次些帶權的並查集要是發現錯誤歡迎指正。