1. 程式人生 > 其它 >Red and Black-DFS

Red and Black-DFS

技術標籤:#DFS搜尋演算法佇列

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9

.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output
45
59
6
13

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int w,h,book[50][50],ss;
char s[110][110];
typedef struct
{
	int x,y;
}S;
S q[1010];
int main()
{
	int l,i,j,k,n;
	while(scanf("%d%d",&w,&h)!=EOF)
	{
		 ss=0;
	     if(w==0&&h==0)
	     break;
	     for(i=0;i<h;i++)
	     scanf("%s",s[i]);
	     for(i=0;i<h;i++)
	     {
	     	for(j=0;j<w;j++)
	     	{
	     		if(s[i][j]=='@')
	     		{
	     			ss=1;
					 break;
				 }
			 }
			 if(ss==1)
			 break;
		 }
		 s[i][j]='#';
		 int head,tail,tx,ty,f;
		 head=tail=1;
		 q[tail].x =i,q[tail].y=j;
		 tail++;
		 memset(book,0,sizeof(book));
		 book[i][j]=1;//標記
		 int e[4][2]={{1,0},{0,1},{-1,0},{0,-1}};//方向
		 //佇列,進了多少佇列就有多少 
		 while(head<tail)
		 {
		 	for(i=0;i<4;i++)//遍歷四個方向
		 	{
		 		tx=q[head].x+e[i][0],ty=q[head].y+e[i][1];//用head遍歷四個方向
		 		if(tx<0||tx>h-1||ty<0||ty>w-1||s[tx][ty]=='#')//範圍
		 		continue;
		 		if(book[tx][ty]==0&&s[tx][ty]=='.')//沒有遍歷
		 		{
		 			book[tx][ty]=1;//標記遍歷過了
		 			q[tail].x=tx;q[tail].y=ty;//進隊
		 			tail++;//用tail控制佇列
				}
			 }
			 head++;
		 }
		 	printf("%d\n",tail-1);//最後輸出進隊多少即是最少
	}
	
}