1. 程式人生 > 其它 >POJ 2488 A Knight‘s Journey(dfs)

POJ 2488 A Knight‘s Journey(dfs)

技術標籤:深度優先搜尋c++dfs

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

在這裡插入圖片描述

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

思路

用深度優先搜尋,注意向四周搜尋是有順序的,來實現輸出字典序最小的。一個搜尋不成功,要有回溯,刪除標記。
另外,注意輸出的格式

程式碼

#include<iostream>
#include<cstring>
using namespace std;

int vis[30][30];
const int xx[8]={-1,1,-2,2,-2,2,-1,1};  
const int yy[8]={-2,-2,-1,-1,1,1,2,2};	//!!順序
struct node
{
	int x,y;							//座標 
}s[30];
int p,q,num,work;

void dfs(int x,int y)
{
	s[num].x=x;							//存入此步 
	s[num].y=y;
	if(num==p*q)
	{
		work=1;							//都走完 
		return;
	}
	for(int i=0;i<8;i++)
	{
		int dx=x+xx[i],dy=y+yy[i];
		if(dx>0&&dx<=p&&dy>0&&dy<=q&&vis[dx][dy]==0)
		{
			vis[dx][dy]=1;				//標記格子 
			num++;
			dfs(dx,dy);					
			num--;						//回溯 
			vis[dx][dy]=0;
		}
		if(work)
			return;
	}
}

int main()
{
	int t;
	cin>>t;
	int o=t;
	int cnt=0;
	while(t--)
	{
		++cnt;
		memset(vis,0,sizeof(vis));		//重置 
		num=1;
		cin>>p>>q;
		cout<<"Scenario #"<<cnt<<":"<<endl;
		vis[1][1]=1;					//標記初始位置
		work=0;
		dfs(1,1);
		if(work)
		{
			for(int i=1;i<=p*q;i++)		
				cout<<(char)(s[i].y+'A'-1)<<s[i].x;
			cout<<endl;
		}
		else
			cout<<"impossible"<<endl;
		if(cnt!=o)
			cout<<endl;
	}
	return 0;
}