1. 程式人生 > 其它 >Ignatius and the Princess III DP

Ignatius and the Princess III DP

Ignatius and the Princess III

Problem Description
“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
4
10
20

Sample Output
5
42
627

#include<bits/stdc++.h>
using namespace std;
int i,j,dp[121]={0},n,s[121];
void fun()
{
    for(i=0;i<121;i++)
    {
        s[
i]=i; } dp[0]=1; for(i=1;i<121;i++) { for(j=s[i];j<121;j++) { dp[j]=dp[j-s[i]]+dp[j]; } } } int main() { fun(); while(cin>>n) { printf("%d\n",dp[n]); } }