1. 程式人生 > 其它 >1047 Student List for Course (25 分)

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers:N(≤), the total number of students, andK(≤), the total number of courses. ThenNlines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive numberC(≤) which is the number of courses that this student has registered, and then followed byCcourse numbers. For the sake of simplicity, the courses are numbered from 1 toK.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
思路:為每一個課程建立一個vector陣列,儲存選擇該門課的學生
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
vector<vector<string> > ve;
bool cmp(string a,string b){
    return a<b;
}
int main(){
    int m,n;
    scanf("%d %d",&m,&n);
    ve.resize(m);
    for(int i=0;i<m;i++){
        string st;
        int rig,stu;
        cin>>st;
        scanf("%d",&rig);
        for(int j=0;j<rig;j++){
            scanf("%d",&stu);
            ve[stu-1].push_back(st);
        }
    }
    for(int i=0;i<n;i++){
        printf("%d %d\n",i+1,ve[i].size());
        sort(ve[i].begin(),ve[i].end(),cmp);
        for(int j=0;j<ve[i].size();j++){
            printf("%s\n",ve[i][j].c_str());
        }
    }
    return 0;
}