1. 程式人生 > 其它 >1002 A+B for Polynomials (25分) PAT_A

1002 A+B for Polynomials (25分) PAT_A

技術標籤:PAT甲級

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K

is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

~

這個N是小於等於1000的,開個陣列就行。

程式碼

// 測試點 1 3 4 5 沒有考慮 保留一位小數
//
#include <iostream>

using namespace std;
double arr1[1001], arr2[1001];
int main()
{
    int N;

    cin >> N;
    while (N--)
    {
        int n;
        double a;
cin >> n >> a; arr1[n] = a; } cin >> N; while (N--) { int n; double a; cin >> n >> a; arr2[n] = a; } int cnt = 0; for (int i = 0; i < 1001; ++i) { arr1[i] += arr2[i]; if (arr1[i]) ++cnt; } cout << cnt; for (int i = 1000; i >= 0; --i) { if (arr1[i]) printf(" %d %.1f", i, arr1[i]); } }