1. 程式人生 > 其它 >1083 List Grades (25 分)(排序)

1083 List Grades (25 分)(排序)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output “NONE” instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

生詞

英文 解釋
boundaries 邊界
interval 區間

題目大意:

給出n個考生的資訊,按照分數從高到低排序,並且輸出給定區間的考生資訊。如果不存在滿足條件的考生就輸出NONE

分析:

建立結構體陣列,將不滿足條件的學生grade改為-1,並統計滿足條件的學生的個數cnt,然後進行排序,輸出前cnt個考生的資訊~

注意:

因為每個學生的成績都不同,所以按照下降排列即可,return a.grade > b.grade;

原文連結:https://blog.csdn.net/liuchuo/article/details/52146657

題解

#include <bits/stdc++.h>

using namespace std;
struct peo
{
    string name,id;
    int grade;
};
bool cmp(peo a,peo b){
    return a.grade>b.grade;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,a,b;
    cin>>n;
    vector<peo> stu(n),re;
    for(int i=0;i<n;i++){
        cin>>stu[i].name>>stu[i].id>>stu[i].grade;
    }
    cin>>a>>b;
    for(int i=0;i<n;i++){
        if(stu[i].grade>=a&&stu[i].grade<=b){
            re.push_back(stu[i]);
        }
    }
    sort(re.begin(),re.end(),cmp);
    if(re.size()!=0){
        for(int i=0;i<re.size();i++)
            cout<<re[i].name<<" "<<re[i].id<<endl;
    }else{
        cout<<"NONE"<<endl;
    }
    return 0;
}

本文來自部落格園,作者:勇往直前的力量,轉載請註明原文連結:https://www.cnblogs.com/moonlight1999/p/15758425.html