「POJ2083」Fractal 題解 (遞迴,分形)
題目簡介
Description|題目描述
A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
A box fractal of degree 1
X
A box fractal of degree 2 is
X X
X
X X
If using \(B(n - 1)\) to represent the box fractal of degree \(n - 1\), then a box fractal of degree n is defined recursively as following \[B(n - 1) B(n - 1) \]\[B(n - 1) \]\[B(n - 1)B(n - 1) \]
Your task is to draw a box fractal of degree \(n\)
分形是在某種技術意義上在所有尺度上顯示自相似性的物件或數量。 物體不需要在所有尺度上都具有完全相同的結構,但是相同的“型別”結構必須出現在所有尺度上。
箱形分形定義如下:
1級的盒子分形是簡單的
X
2級的盒子分形是
X X
X
X X
如果使用\(B(n - 1)\)來表示\(n - 1\)的盒子分形,那麼遞迴地定義n階的盒子分形如下
你的任務是繪製一個度為\(n\)的盒子分形。
Input|輸入
The input consists of several test cases. Each line of the input contains a positive integer \(n\)
輸入包含幾個測試用例。 輸入的每一行包含一個不大於\(7\)的正整數\(n\)。輸入的最後一行是負整數\(-1\),表示輸入的結束。
Output|輸出
For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.
對於每個測試用例,使用“X”符號輸出框分形。 請注意'X'是一個大寫字母。 在每個測試用例後列印一行只有一個短劃線。
Sample Input|樣例輸入
1
2
3
4
-1
Sample Output|樣例輸出
X
-
X X
X
X X
-
X X X X
X X
X X X X
X X
X
X X
X X X X
X X
X X X X
-
X X X X X X X X
X X X X
X X X X X X X X
X X X X
X X
X X X X
X X X X X X X X
X X X X
X X X X X X X X
X X X X
X X
X X X X
X X
X
X X
X X X X
X X
X X X X
X X X X X X X X
X X X X
X X X X X X X X
X X X X
X X
X X X X
X X X X X X X X
X X X X
X X X X X X X X
-
分析
經過分析
\(i\)級分形盒子 | 行數 | 行表示方法 | 列數 | 列的表示方法 |
---|---|---|---|---|
$$1$$ | $$1$$ | \(0\sim 3^0-1\) | $$1$$ | \(0\sim 3^0-1\) |
$$2$$ | $$3$$ | \(0\sim 3^1-1\) | $$3$$ | \(0\sim 3^1-1\) |
$$3$$ | $$9$$ | \(0\sim 3^2-1\) | $$9$$ | \(0\sim 3^2-1\) |
$$4$$ | $$27$$ | \(0\sim 3^3-1\) | $$27$$ | \(0\sim 3^3-1\) |
- 1.定義一個\(E\)陣列
int E[10];
E[0]=1;
for(int i=1;i<8;i++)E[i]=E[i-1]*3;
- 2.我們還需要一個\(char\)型別的\(G\)陣列記錄地圖
while(scanf("%d",&n)){
if(n==-1)break;
memset(G,' ',sizeof(G));
}
記得在每行的末尾打一個終止符'\0'
:
for(int i=0;i<E[n-1];i++)
G[i][E[n-1]]='\0';
- 3.遞迴
B(n,0,0);
inline void B(int n,int x,int y){
if(n==1){
G[x][y]='X';
return ;
}
B(n-1,x,y);//左上
B(n-1,x,y+(E[n-2]<<1));//右上
B(n-1,x+E[n-2],y+E[n-2]);//正中
B(n-1,x+(E[n-2]<<1),y);//左下
B(n-1,x+(E[n-2]<<1),y+(E[n-2]<<1));//右下
}
程式碼
#include<bits/stdc++.h>
using namespace std;
int E[10];
char G[1010][1010];
inline void B(int n,int x,int y){
if(n==1){
G[x][y]='X';
return ;
}
B(n-1,x,y);
B(n-1,x,y+(E[n-2]<<1));
B(n-1,x+E[n-2],y+E[n-2]);
B(n-1,x+(E[n-2]<<1),y);
B(n-1,x+(E[n-2]<<1),y+(E[n-2]<<1));
}
int main(){
int n;
E[0]=1;
for(int i=1;i<8;i++)E[i]=E[i-1]*3;
while(scanf("%d",&n)){
if(n==-1)break;
memset(G,' ',sizeof(G));
for(int i=0;i<E[n-1];i++)
G[i][E[n-1]]='\0';
B(n,0,0);
for(int i=0;i<E[n-1];i++)
puts(G[i]);
puts("-");
}
return 0;
}