1022 Digital Library (30 分)(map)
A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:
- Line #1: the 7-digit ID number;
- Line #2: the book title -- a string of no more than 80 characters;
- Line #3: the author -- a string of no more than 80 characters;
- Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
- Line #5: the publisher -- a string of no more than 80 characters;
- Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.
After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:
- 1: a book title
- 2: name of an author
- 3: a key word
- 4: name of a publisher
- 5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.
Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
生詞
英文 | 解釋 |
---|---|
query | 查詢 |
題目大意:
模擬數字圖書館的查詢功能。會給出n本書的資訊,以及m個需要查詢的命令,數字標號對應相應的命令,數字編號後面的字串是查詢的搜尋詞,要求輸出這行命令以及輸出滿足條件的書的id,如果一個都沒有找到,輸出Not Found
分析:
1、對除了id之外的其他資訊都建立一個map<string, set>,把相應的id插入對應搜尋詞的map的集合裡面,形成一個資訊對應一個集合,集合裡面是複合條件的書的id
2、因為對於輸入的關鍵詞(可以重複,算是書本對應的tag標籤吧~)沒有給定關鍵詞的個數,可以使用while(cin >> s)並且判斷c = getchar(),c是否等於\n,如果是再退出迴圈~
3、建立query,通過傳參的形式可以將不同的map名稱統一化,先要判斷map.find()和m.end()是否相等(或者判斷m[str].size()==0?),如果不等再去遍歷整個map,輸出所有滿足條件的id,如果相等就說明不存在這個搜尋詞對應的id,那麼就要輸出Not Found~
4、傳參一定要用引用,否則最後一組資料可能會超時~
原文連結:https://blog.csdn.net/liuchuo/article/details/52263303
22分題解
失分分析:
本來覺得用一個map就行,後來發現如果title、author、key、pub和year如果有相同的值,那麼也會出問題。
舉個栗子:
2
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
keywords
test code sort keywords
ZUCS Print2
2012
可以發現第一個的key裡的keywords與第二個的author相同,所以查詢keywords時兩者都會輸出,而這樣是不對的。
解決方法
分別用不同的map記錄即可~
#include <bits/stdc++.h>
using namespace std;
map<string,set<int> > m;
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("1.txt", "r", stdin);
#endif
int n,M,id;
string s;
scanf("%d",&n);
for(int i=0;i<n;i++){
cin>>id;
//title
getchar();getline(cin,s);
//cout<<"title:"<<s<<endl;
m[s].insert(id);
//author
getline(cin,s);
//cout<<"author:"<<s<<endl;
m[s].insert(id);
//key
while(cin>>s){
//cout<<"key:"<<s<<endl;
m[s].insert(id);
char c=getchar();
if(c=='\n') break;
}
//pub
getline(cin,s);
//cout<<"pub:"<<s<<endl;
m[s].insert(id);
//year
cin>>s;
//cout<<"year:"<<s<<endl;
m[s].insert(id);
}
scanf("%d",&M);
for(int i=0;i<M;i++){
scanf("%d: ",&id);
getline(cin,s);
cout<<id<<": "+s<<endl;
if(m[s].size()==0){
cout<<s<<endl;
cout<<"Not Found"<<endl;
continue;
}
set<int>::iterator it;
for(it=m[s].begin();it!=m[s].end();it++)
cout<<*it<<endl;
}
return 0;
}
正確題解
小技巧:
while(cin>>s){ //cout<<"key:"<<s<<endl; key[s].insert(id); char c=getchar(); if(c=='\n') break; }
多項輸入換行結束的判斷~
#include <bits/stdc++.h>
using namespace std;
map<string,set<int> > title, author, key, pub, year;
void query(map<string,set<int> > &m,string &str){
//每一個m[str]相當於一個set<int>
//柳神這裡用的是m.find(str) != m.end()判斷
if(m[str].size()!=0){
//這裡就是遍歷set的值
for(auto it=m[str].begin();it!=m[str].end();it++)
printf("%07d\n",*it);
}else printf("Not Found\n");
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("1.txt", "r", stdin);
#endif
int n,M,id;
string s;
scanf("%d",&n);
for(int i=0;i<n;i++){
cin>>id;
//title
getchar();getline(cin,s);
//cout<<"title:"<<s<<endl;
title[s].insert(id);
//author
getline(cin,s);
//cout<<"author:"<<s<<endl;
author[s].insert(id);
//key
while(cin>>s){
//cout<<"key:"<<s<<endl;
key[s].insert(id);
char c=getchar();
if(c=='\n') break;
}
//pub
getline(cin,s);
//cout<<"pub:"<<s<<endl;
pub[s].insert(id);
//year
cin>>s;
//cout<<"year:"<<s<<endl;
year[s].insert(id);
}
scanf("%d",&M);
for(int i=0;i<M;i++){
scanf("%d: ",&id);
getline(cin,s);
cout<<id<<": "+s<<endl;
if(id==1) query(title,s);
else if(id==2) query(author,s);
else if(id==3) query(key,s);
else if(id==4) query(pub,s);
else if(id==5) query(year,s);
}
return 0;
}
本文來自部落格園,作者:勇往直前的力量,轉載請註明原文連結:https://www.cnblogs.com/moonlight1999/p/15522300.html