1. 程式人生 > 實用技巧 >B - B Saruman's Army(貪心)

B - B Saruman's Army(貪心)

在一條直線上,有n個點。從這n個點中選擇若干個,給他們加上標記。對於每一個點,其距離為R以內的區域裡必須有一個被標記的點。問至少要有多少點被加上標記

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range ofR

units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is withinRunits of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integerR, the maximum effective range of all palantirs (where 0 ≤R≤ 1000), and an integern, the number of troops in Saruman’s army (where 1 ≤n≤ 1000). The next line contains n integers, indicating the positionsx

1, …,xnof each troop (where 0 ≤xi≤ 1000). The end-of-file is marked by a test case withR=n= −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

題解:我們從最左邊的開始考慮。對於這個點,到距其R以內的區域必須要有帶有標記的點。帶有標記的點一定在其右側(包含這個點本身)。給從最左邊開始,距離為R以內的最遠的點加上標記,儘可能的覆蓋更靠右邊的點。對於添加了標記的點右側相距超過R的下一個點,採用同樣的方法找到最右側R距離以內最遠的點新增標記。在所有點都被覆蓋之前不斷重複這一過程。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[1010];
int main()
{
    int n,r;
    while(~scanf("%d%d",&r,&n)&&(n+r)!=-2)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        scanf("%d",&dp[i]);
        int ans=0;
        sort(dp+1,dp+n+1);
        int i=1;
        while(i<=n)
        {
            int s=dp[i++];
            while(i<=n&&dp[i]<=s+r)
                i++;
            int p=dp[i-1];
            while(i<=n&&dp[i]<=p+r)
                i++;
            ans++;
        }
        printf("%d\n",ans);
    }
}