1. 程式人生 > >codevs1160 蛇形矩陣

codevs1160 蛇形矩陣

desc std 方向 can 方法 main head pan num

題目描述 Description

小明玩一個數字遊戲,取個n行n列數字矩陣(其中n為不超過100的奇數),數字的填補方法為:在矩陣中心從1開始以逆時針方向繞行,逐圈擴大,直到n行n列填滿數字,請輸出該n行n列正方形矩陣以及其的對角線數字之和.

輸入描述 Input Description

n(即n行n列)

輸出描述 Output Description

n+1行,n行為組成的矩陣,最後一行為對角線數字之和

樣例輸入 Sample Input

3

樣例輸出 Sample Output

5 4 3
6 1 2
7 8 9
25

#include <stdio.h>
#include <string.h>
int main(){
	int a[110][110];
	int n,x,y,tot,num=0;
	scanf("%d",&n);
	memset(a,0,sizeof(a));
	tot=n*n;
	a[x=n-1][y=n]=n*n;
	while(tot>0){
		while(y-1>=0 && !a[x][y-1]) a[x][--y]=--tot;
		while(x-1>=0 && !a[x-1][y]) a[--x][y]=--tot;
		while(y+1<n && !a[x][y+1]) a[x][++y]=--tot;
		while(x+1<n && !a[x+1][y]) a[++x][y]=--tot;
	}
	for(x=0;x<n;x++){
		for(y=0;y<n;y++)printf("%d ",a[x][y]+1);
		printf("\n");
	}
	for(x=0;x<n;x++)
		for(y=0;y<n;y++){
			if(x==y || x+y==n-1)num+=a[x][y]+1;
	}
	printf("%d\n",num);
	return 0;
}

codevs1160 蛇形矩陣