1. 程式人生 > >codevs 1160 蛇形矩陣

codevs 1160 蛇形矩陣

ani blog space 對角線 cstring math 數字 hint clu

題目描述 Description

小明玩一個數字遊戲,取個n行n列數字矩陣(其中n為不超過100的奇數),數字的填補方法為:在矩陣中心從1開始以逆時針方向繞行,逐圈擴大,直到n行n列填滿數字,請輸出該n行n列正方形矩陣以及其的對角線數字之和.

輸入描述 Input Description

n(即n行n列)

輸出描述 Output Description

n+1行,n行為組成的矩陣,最後一行為對角線數字之和

樣例輸入 Sample Input

3

樣例輸出 Sample Output

5 4 3
6 1 2
7 8 9
25

數據範圍及提示 Data Size & Hint
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<iomanip>
using namespace std;
int a[101][101]={0};
int main()
{
    int n,tot=1;
    cin>>n;
    int i=(n+1)/2;
    int j=(n+1)/2;
    a[i][j]
=tot; int m=i; int p=j; for(int w=1;w<=(n-1)/2;w++) { while(p<j+w) { tot++; p++; a[m][p]=tot; } while(m>(i-w)) { m--; tot++; a[m][p]=tot; } while(p>j-w) { p
--; tot++; a[m][p]=tot; } while(m<i+w) { m++; tot++; a[m][p]=tot; } while(p<j+w) { tot++; p++; a[m][p]=tot; } } int sum=0; for(int i=1;i<=n;i++) { for( j=1;j<=n;j++) { if(i==j||i+j==n+1) { sum+=a[i][j]; } } } for(int i=1;i<=n;i++) { for( j=1;j<=n;j++) { cout<<a[i][j]<<" "; } cout<<endl; } cout<<sum<<endl; return 0; }

codevs 1160 蛇形矩陣