1. 程式人生 > >POJ 3786 dp-遞推 Adjacent Bit Counts *

POJ 3786 dp-遞推 Adjacent Bit Counts *

num new red rip int chosen star program http

Adjacent Bit Counts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 599 Accepted: 502

Description

For a string of n bits x1, x2, x3, …, xn, the adjacent bit count of the string (AdjBC(x)) is given by

x1*x2 + x2*x3 + x3*x4 + … + xn-1*xn

which counts the number of times a 1 bit is adjacent to another 1 bit. For example:

AdjBC(011101101) = 3
AdjBC(111101101) = 4
AdjBC(010101010) = 0

Write a program which takes as input integers n and k and returns the number of bit strings x of n bits (out of 2?) that satisfy AdjBC(x) = k. For example, for 5 bit strings, there are 6 ways of getting AdjBC(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (k) giving the desired adjacent bit count. The number of bits (n) will not be greater than 100 and the parameters n and k will be chosen so that the result will fit in a signed 32-bit integer.

Output

For each data set there is one line of output. It contains the data set number followed by a single space, followed by the number of n-bit strings with adjacent bit count equal to k.

Sample Input

10 
1 5 2 
2 20 8 
3 30 17 
4 40 24 
5 50 37 
6 60 52 
7 70 59 
8 80 73 
9 90 84 
10 100 90

Sample Output

1 6
2 63426
3 1861225
4 168212501
5 44874764
6 160916
7 22937308
8 99167
9 15476
10 23076518

Source

Greater New York Regional 2009
  1. 由0,1組成的長度為n的數列x1,x2,x3,x4.....xn,定義一個操作為
  2. AdjBC(x) = x1*x2 + x2*x3 + x3*x4 + … + xn-1*xn 。
  3. 輸入兩個數n和m,求長度為n的數列,經過上述操作,最後結果為m共有多少種
  4. 思路 : DP,遞推
  5. d[i][j][0]:表示前i項組成和為j且第i項為0共有多少種
  6. d[i][j][1]:表示前i項組成和為j且第i項為1共有多少種
  7. 狀態轉移方程:
  8. d[i][j][1] = d[i-1][j][0] + d[i-1][j-1][1];
  9. d[i][j][0] = d[i-1][j][1] + d[i-1][j][0]
    #include <stdio.h>
    #include <math.h>
    #include <iostream>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    #define maxn 105
    using namespace std;
    int main()
    {
        int t,n,m;
        int dp[maxn][maxn][2];
        dp[1][0][0] = dp[1][0][1] = 1;
        for(int i=2;i<maxn;i++){
            dp[i][0][0] = dp[i-1][0][1] + dp[i-1][0][0];
            dp[i][0][1] = dp[i-1][0][0];
        }
        for(int i=2;i<maxn;i++){
            for(int j=1;j<maxn;j++){
                dp[i][j][0] = dp[i-1][j][0] + dp[i-1][j][1];
                dp[i][j][1] = dp[i-1][j][0] + dp[i-1][j-1][1];
            }
        }
        int T;
        cin >> T;
        while(T--){
            cin >> t >> n >> m;
            cout << t << " " << dp[n][m][0]+dp[n][m][1] << endl;
        }
        return 0; 
    }

POJ 3786 dp-遞推 Adjacent Bit Counts *