1. 程式人生 > >1014. Waiting in Line (30)

1014. Waiting in Line (30)

not posit con red bsp ransac blog else where

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1

is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry

本題主要考的是優先隊列的使用。首先在優先隊列裏存儲n*m個客戶的結束時間end_time及開始時間start_time,並記錄各自屬於哪個窗口。額外由
line_end_time[n]數組記錄每個窗口的在黃線內最後的處理時間T。當處理第n*m+1的客戶C時,由優先隊列取出最早結束的客戶c1,此時客戶C的
開始時間即為c1所在窗口的T,結束時間為開始時間加上C的處理時間,並更新它所在窗口的最後處理時間。


#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<queue>
#include <vector>
#include<string.h>
using namespace std;
struct Customer{
	int window_id;
	int start_time;
	int process_time;
	int end_time;
	bool operator < (const Customer tmp) const {
		if( end_time == tmp.end_time){
			return window_id > tmp.window_id;
		} else{
			return end_time > tmp.end_time;
		}
	}
};
const int max_customer = 1002;
struct Customer customer[max_customer];
priority_queue<Customer>con_queue_line;
int n,m,k,q;
int query[max_customer];
int line_end_time[21];
int main(){
	scanf("%d%d%d%d",&n,&m,&k,&q);
	int i,j;
	for(i=1;i<=k;i++){
		scanf("%d",&customer[i].process_time);
		customer[i].end_time =0;
		customer[i].start_time =0;
	}
	for(i=1;i<=q;i++){
		scanf("%d",&query[i]);
	}
	memset(line_end_time,0,sizeof(line_end_time));
	int flag=0;
	Customer c;
	for(i=1;i<=m && flag<k; i++){
		for(j=0;j<n && flag<k; j++){
			flag ++;
			c.start_time = line_end_time[j];
			c.window_id = j;
			c.end_time = c.start_time + customer[flag].process_time;
			line_end_time[j] = c.start_time + customer[flag].process_time;
			customer[flag].window_id = c.window_id;
			customer[flag].end_time = c.end_time;
			customer[flag].start_time = c.start_time;
			con_queue_line.push(c);
		}
	}
	Customer tmp;
	for(i=flag+1;i<=k;i++){
		c = con_queue_line.top();
		con_queue_line.pop();		
		tmp.start_time = line_end_time[c.window_id];
		tmp.window_id = c.window_id;
		tmp.end_time = customer[i].process_time + tmp.start_time;
		line_end_time[c.window_id] = customer[i].process_time + tmp.start_time;
		customer[i].end_time = tmp.end_time;
		customer[i].start_time = tmp.start_time;
		customer[i].window_id = tmp.window_id;
		con_queue_line.push(tmp);
	}
	int c_id;
	int time = (17-8)*60;
	for(i = 1;i<=q;i++){
		c_id = query[i];
		if(customer[c_id].start_time >= time){
			printf("Sorry\n");
		} else {
			int h = customer[c_id].end_time/60;
			int m = customer[c_id].end_time%60;
			printf("%02d:%02d\n",h+8,m);
		}
	}
	return 0;
}

  

1014. Waiting in Line (30)