1. 程式人生 > >2015北京區域賽 Xiongnu's Land

2015北京區域賽 Xiongnu's Land

sam gns end res ken 二分法 over r+ log

Wei Qing (died 106 BC) was a military general of the Western Han dynasty whose campaigns against
the Xiongnu earned him great acclaim. He was a relative of Emperor Wu because he was the younger
half-brother of Empress Wei Zifu (Emperor Wu’s wife) and the husband of Princess Pingyang. He was
also the uncle of Huo Qubing, another notable Han general who participated in the campaigns against
the Xiongnu and exhibited outstanding military talent even as a teenager.
Defeated by Wei Qing and Huo Qubing, the Xiongnu sang: “Losing my Qilian Mountains, made
my cattle unthriving; Losing my Yanzhi Mountains, made my women lacking rouge.”
The text above is digested from Wikipedia. Since Wei and Huo’s distinguished achievements,
Emperor Wu decided to give them some awards — a piece of land taken by them from Xiongnu. This
piece of land was located in a desert, and there were many oases in it. Emperor Wu wanted to draw
a straight south-to-north dividing line to divide the land into two parts, and gave the western part to
Wei Qing while gave the eastern part to Huo Qubing. There are two rules about the land dividing:
1. The total area of the oases lay in Wei’s land must be larger or equal to the total area of the oases
lay in Huo’s land, and the difference must be as small as possible.
2. Emperor Wu wanted Wei’s land to be as large as possible without violating the rule 1.
To simplify the problem, please consider the piece of land given to Wei and Huo as a square on a
plane. The coordinate of its left bottom corner was (0,0) and the coordinate of its right top corner
was (R, R). Each oasis in this land could also be considered as a rectangle which was parallel to the
coordinate axes. The equation of the dividing line was like x = n, and n must be an integer. If the
dividing line split an oasis, then Wei owned the western part and Huo owned the eastern part. Please
help Emperor Wu to find out how to draw the dividing line.
Input
The first line of the input is an integer K meaning that there are K (1 ≤ K ≤ 15) test cases.
For each test case:
The first line is an integer R, indicating that the land’s right top corner was at (R, R) (1 ≤ R ≤
1,000,000)
Then a line containing an integer N follows, indicating that there were N (0 < N ≤ 10000) oases.
Then N lines follow, each contains four integers L, T, W and H, meaning that there was an
oasis whose coordinate of the left top corner was (L, T), and its width was W and height was H.
(0 ≤ L, T ≤ R, 0 < W, H ≤ R). No oasis overlaps.
Output
For each test case, print an integer n, meaning that Emperor Wu should draw a dividing line whose
equation is x = n. Please note that, in order to satisfy the rules, Emperor might let Wei get the whole
land by drawing a line of x = R if he had to.
Sample Input
2
1000
2
1 1 2 1
5 1 2 1
1000
1
1 1 2 1
Sample Output
5
2

題意:沙漠中有許多塊矩形水源,水源不相交,問能否找到一根中軸線,使得軸線左邊的水源面積大於等於右邊的水源面積。在滿足兩個面積之差最小的情況下,使得軸線靠近右端點

用二分法求,否則時間超限

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int n;
struct point{
    int x,y,w,h;
};
point a[10010];
/*bool cmp(point p,point q){
    return p.x<q.x;
}
*/ ll cal(int x){ ll sum = 0; for(int i=0;i<n;i++){ if(a[i].x < x){ sum += (ll)( min( (a[i].w+a[i].x),x) - a[i].x) * a[i].h; } } return sum; } int main(){ int T,R,w,h; ll total; while(cin >> T){ while(T--){ total = 0
; cin >> R; cin >> n; for(int i=0;i<n;i++){ cin >> a[i].x >> a[i].y >> a[i].w >> a[i].h; total += (ll)a[i].h*a[i].w;//註意每次都要取long long 否則答案錯誤 } // sort(a,a+n,cmp); int l,r,mid; ll tmp; l = 0,r = R; while(l<r){ mid = (r+l)/2; tmp = cal(mid); if(2*tmp<total){ l = mid + 1; }else r = mid; } tmp = cal(r); while(cal(r) == tmp && r<=R){ r ++; } cout << r-1 << endl; } } return 0; }

2015北京區域賽 Xiongnu's Land