1. 程式人生 > >POJ 3436 ACM Computer Factory

POJ 3436 ACM Computer Factory

image src rem period clu lan is a set decided front

                              ACM Computer Factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8632 Accepted: 3140 Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn‘t matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part j, Di,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ N ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.

Source

Northeastern Europe 2005, Far-Eastern Subregion 題意: 有p個零部件,n臺機器 接下來n行,每行 第一個數字表示這臺機器最多能組裝幾個零部件, 後面p個數,表示要由這臺機器組裝,零部件要滿足的條件 ,可能為0,1,2,分別表示這個零部件必須還沒有組裝,必須已經組裝,組裝不組裝都行 後面再p個數 ,表示由這臺機器組裝完畢後,零部件的情況,可能為0,1,分別表示 這個零部件沒有組裝,已經組裝。 思路:網絡流先拆點再跑最大流。 建圖: 1.把每臺機器拆成兩個點,第i臺機器與其拆點的i+n臺機器連一條流量為機器產量的邊。 2.如果第i臺機器要生產的零件是全部沒有生產過的,就把i向源點連一條流量為inf的邊。 3.如果第i臺機器生產後的零件為全部生產完成的,就把i+n向匯點連一條流量為inf的邊。 4.如果第i臺機器生產完之後的零件狀況與第j臺機器生產之前的零件狀況相互吻合,就從i+n向j連一條流量為inf的邊。 第一個樣例的圖如下所示: 技術分享圖片 求各位大佬看看為什麽wa了。
#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 30000
using namespace std;
int p,n,tot=1;
int src,decc,ans;
int out[MAXN][4];
int cur[MAXN],lev[MAXN];
int be[MAXN][11],en[MAXN][11];
int to[MAXN*2],cap[MAXN*2],net[MAXN*2],head[MAXN];
void clearn(){
    tot=1;ans=0;
    memset(head,0,sizeof(head));
}
void add(int u,int v,int w){
    to[++tot]=v;cap[tot]=w;net[tot]=head[u];head[u]=tot;
    to[++tot]=u;cap[tot]=0;net[tot]=head[v];head[v]=tot;
}
bool bfs(){
    queue<int>que;
    for(int i=src;i<=decc;i++){
        lev[i]=-1;
        cur[i]=head[i];
    }
    que.push(src);lev[src]=0;
    while(!que.empty()){
        int now=que.front();
        que.pop();
        for(int i=head[now];i;i=net[i])
            if(lev[to[i]]==-1&&cap[i]>0){
                que.push(to[i]);
                lev[to[i]]=lev[now]+1;
                if(to[i]==decc)    return true;
            }
    }
    return false;
}
int dinic(int now,int flow){
    if(now==decc)    return flow;
    int rest=0,detal;
    for(int & i=cur[now];i;i=net[i])
        if(lev[to[i]]==lev[now]+1&&cap[i]>0){
            detal=dinic(to[i],min(flow-rest,cap[i]));
            if(detal){
                rest+=detal;
                cap[i]-=detal;
                cap[i^1]+=detal;
                if(rest==flow)    break;
            }
        }
    if(rest!=flow)    lev[now]=1;
    return rest;
}
int main(){
    while(scanf("%d%d",&p,&n)!=EOF){
        src=0;decc=2*n+1;
        for(int i=1;i<=n;i++){
            int m;scanf("%d",&m);
            add(i,i+n,m);
            for(int j=1;j<=p;j++)    scanf("%d",&be[i][j]);
            for(int j=1;j<=p;j++)    scanf("%d",&en[i][j]);
        }
        for(int i=1;i<=n;i++){
            int sum1=0,sum2=0;
            for(int j=1;j<=p;j++){
                if(be[i][j]==0)    sum1++;
                if(en[i][j]==1)    sum2++;
            }
            if(sum1==p)    add(src,i,0x7f7f7f7f);
            if(sum2==p)    add(i+n,decc,0x7f7f7f7f);
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i!=j){
                    int sum=0;
                    for(int k=1;k<=p;k++)
                        if(en[i][k]==be[j][k]||en[i][k]==2||be[j][k]==2)    sum++;
                    if(sum==p)    add(i+n,j,0x7f7f7f7f);
                }
        while(bfs())    
            ans+=dinic(src,0x7f7f7f7f);
        printf("%d ",ans);
        int sum=0;
        for(int i=1;i<=n;i++){
            for(int j=head[n+i];j;j=net[j]){
                if(to[j]==decc||cap[j]==0x7f7f7f7f||to[j]==i)    continue;
                sum++;out[sum][1]=i;
                out[sum][2]=to[j];
                out[sum][3]=0x7f7f7f7f-cap[j];
            }
        }
        printf("%d\n",sum);
        for(int i=1;i<=sum;i++)
            printf("%d %d %d\n",out[i][1],out[i][2],out[i][3]);
        clearn();
    }
}

POJ 3436 ACM Computer Factory