1. 程式人生 > >POJ3984 迷宮問題 輸出路徑【BFS】

POJ3984 迷宮問題 輸出路徑【BFS】

%d itl 編程 color struct ++ 維數 node font

題目鏈接

題目大意:

定義一個二維數組:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一個迷宮,其中的1表示墻壁,0表示可以走的路,只能橫著走或豎著走,不能斜著走,要求編程序找出從左上角到右下角的最短路線。
Input

一個5 × 5的二維數組,表示一個迷宮。數據保證有唯一解。
Output

左上角到右下角的最短路徑,格式如樣例所示。


Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0


Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

#include <cstdio>                       
#include <cstring>
int array[5][5];
int vis[5][5];
int dir[4][2] = {1,0,0,1,-1,0,0,-1};
struct node
{
    int x, y;
    int pre;
};
node que[100];

void print(node s)
{
    if (s.pre != -1)print(que[s.pre]);
    printf("(%d, %d)\n", s.x, s.y);
}

void
bfs() { memset(vis, 0, sizeof(vis)); int front = 0, end = 0; node s, t, next; s.x = 0, s.y = 0, s.pre = -1; vis[0][0] = 1; que[end++] = s; while (front < end) { t = que[front]; front++; if (t.x == 4 && t.y == 4) { print(t);
return; } for (int i = 0; i < 4; i++) { int nx = t.x + dir[i][0]; int ny = t.y + dir[i][1]; if (nx < 0 || nx >= 5 || ny < 0 || ny >= 5 || array[nx][ny] == 1)continue; else if (!vis[nx][ny]) { vis[nx][ny] = 1; next.x = nx, next.y = ny; next.pre = front - 1; que[end++] = next; } } } } int main() { int i, j; for (i = 0; i < 5; i++) for (j = 0; j < 5; j++) scanf("%d", &array[i][j]); bfs(); return 0; }

2018-03-31

POJ3984 迷宮問題 輸出路徑【BFS】