1. 程式人生 > >HDU 1025 LIS二分優化

HDU 1025 LIS二分優化

namespace unable itl 優化 int The n) hint mit

題目鏈接:

acm.hdu.edu.cn/showproblem.php?pid=1025

Constructing Roads In JGShining‘s Kingdom

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28755 Accepted Submission(s): 8149


Problem Description JGShining‘s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they‘re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don‘t wanna build a road with other poor ones, and rich ones also can‘t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

技術分享圖片


In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output For each test case, output the result in the form of sample.
You should tell JGShining what‘s the maximal number of road(s) can be built.

Sample Input 2 1 2 2 1 3 1 2 2 3 3 1

Sample Output Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built. Hint
Huge input, scanf is recommended. 題目大意: 兩排城市,要把標號相同的連接起來,但是不能交叉,問至少連幾根線 LIS問題,不過要優化
#include<bits/stdc++.h>
#define max_v 500005
using namespace std;
int a[max_v],dp[max_v],len;
int main()
{
    int n,c=1;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            a[x]=y;
        }
        //dp[k]代表長度為k的LIS序列的最末元素,
        //若有多個長度為k的上升子序列,
        //則記錄最小的那個最末元素
        //dp[]中的元素是單調遞增的,
        //二分優化的時候利用這個性質

        dp[1]=a[1];
        len=1;
        for(int i=2; i<=n; i++)
        {
            if(a[i]>dp[len])
            {
                dp[++len]=a[i];
            }
            else
            {
               int j=lower_bound(dp,dp+len,a[i])-dp;
                dp[j]=a[i];
            }
        }
        if(len==1)
        {
            printf("Case %d:\nMy king, at most %d road can be built.\n\n",c++,len);
        }else
        {
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",c++,len);
        }
    }
    return 0;
}

HDU 1025 LIS二分優化