1. 程式人生 > >HDU 2088 Box of Bricks(腦洞)

HDU 2088 Box of Bricks(腦洞)

mit see after script move real order have ack

傳送門:

http://acm.hdu.edu.cn/showproblem.php?pid=2088

Box of Bricks

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20219 Accepted Submission(s): 6473


Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I‘ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
技術分享圖片

Input The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.

Sample Input 6 5 2 4 1 7 5 0

Sample Output 5

Author qianneng

Source 冬練三九之二 分析: 當時確實沒有想到 :小於平均的棧其差多少的和就是需要移動的總數
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define max_v 50
int a[max_v];
int main()
{
    int n,k=0;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        if(k)
            printf("\n");//註意輸出格式,最後一個測試不能有空行
        int sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sum/=n;//平均
        int c=0;
        for(int i=0; i<n; i++)
        {
            if(a[i]<sum)//小於平均的棧其差多少的和就是需要移動的總數
                c+=(sum-a[i]);
        }
        printf("%d\n",c);
        k++;
    }
    return 0;
}

HDU 2088 Box of Bricks(腦洞)