1. 程式人生 > >PAT 1143 Lowest Common Ancestor[難][BST性質]

PAT 1143 Lowest Common Ancestor[難][BST性質]

cat 輸出 resp 接受 每一個 archive 父節點 itl 技術分享

1143 Lowest Common Ancestor(30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if Ais one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found.

or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

題目大意:給出一棵二叉搜索樹的前序遍歷,並且給出兩個節點,查詢這兩個節點的最近的共同祖先,如果其中一個是另一個的父節點,那麽按格式輸出,如果查不到該節點,那麽根據相應的格式進行輸出。即最小公共祖先。

//既然關鍵字的範圍是int,那麽就不能使用哈西father數組的形式來查找了。

//本來想用map,但是又考慮到會有重復的數,所以就不能用了。

技術分享圖片View Code

//實在是不太會,就寫了這麽點,就是不知道怎麽去給這些node標記父節點。

//看到柳神說這是水題,我的內心接受不了了。。

代碼來自:https://www.liuchuo.net/archives/4616

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, bool> mp;
int main() {
    int m, n, u, v, a;
    scanf("%d %d", &m, &n);
    vector<int> pre(n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &pre[i]);
        mp[pre[i]] = true;//表示這個節點出現了
    }
    for (int i = 0; i < m; i++) {
        scanf("%d %d", &u, &v);
        for(int j = 0; j < n; j++) {
            a = pre[j];//其實每一個節點都是根節點。
            if ((a >= u && a <= v) || (a >= v && a <= u)) break;
            //如果a在兩者之間或者就是當前節點其中一個,
        }
        if (mp[u] == false && mp[v] == false)//false就是都沒有出現,也就是0。
            printf("ERROR: %d and %d are not found.\n", u, v);
        else if (mp[u] == false || mp[v] == false)
            printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
        else if (a == u || a == v)
            printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
        else
            printf("LCA of %d and %d is %d.\n", u, v, a);
    }
    return 0;
}

1.有一個規律,輸入是按照前根遍歷來輸入的,那麽每一個數的前一個數,就是當前數的根節點啊!哪裏用建樹呢?!

2.利用了搜索二叉樹的性質,真是厲害,學習了。

3.判斷a是在u和v之間,還是恰好是u和v.

PAT 1143 Lowest Common Ancestor[難][BST性質]