1. 程式人生 > >HDU 5113 Black And White

HDU 5113 Black And White

reg cal bmi ase its next free this use

Black And White

Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 5859 Accepted Submission(s): 1615
Special Judge


Problem Description In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci
cells.

Matt hopes you can tell him a possible coloring.

Input The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci
(ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .

Output For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.

Sample Input 4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2

Sample Output Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1

Source 2014ACM/ICPC亞洲區北京站-重現賽(感謝北師和上交) Recommend liuyiding 題解: 搜索+減枝優化(判斷是否有顏色的數量超過剩下的方格數量的一半) 參考代碼:
#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define eps 1e-9
#define rep(i,a,n) for(int i=a;i<n;++i)
#define per(i,a,n) for(int i=n-1;i>=a;--i)
#define fi first
#define se second
#define pb push_back
#define np next_permutation
#define mp make_pair
using namespace std;
const int maxn=1e5+5;
const int maxm=1e5+5;

int t,n,m,k,flag;
//dfs 找方案剪枝
int dp[10][10],c[100];
bool check1(int x,int y,int i)
{
	if(x-1>=1 && dp[x-1][y]==i) return false;
	if(y-1>=1 && dp[x][y-1]==i) return false;
	return true;
}
void dfs(int x,int y,int le)
{
	rep(i,1,k+1) if(c[i]>(le+1)/2) return;
	if(flag) return;
	if(x==n+1) { flag=1; return; }
	for(int i=1;i<=k;i++)
	{
		if(c[i])
		{
			if(check1(x,y,i))
			{
				c[i]--;
				dp[x][y] = i;
				if(y==m) dfs(x+1,1,le-1);
				else dfs(x,y+1,le-1);
				if(flag) return;
				c[i]++; dp[x][y] = 0;
			}
		}
	}
} 
int main()
{
	scanf("%d",&t);
	rep(tt,1,t+1)
	{
		flag=0;
		memset(dp,0,sizeof(dp));
		scanf("%d%d%d",&n,&m,&k);
		rep(i,1,k+1) scanf("%d",c+i);
		dfs(1,1,n*m);
		printf("Case #%d:\n",tt);
		if(flag)
		{
			printf("YES");
			rep(i,1,n+1)
			{
				rep(j,1,m) printf("%d ",dp[i][j]);
				printf("%d\n",dp[i][m]);
			}
		}
		else printf("YES");
	}
	return 0;
} 

  

HDU 5113 Black And White