HDU5113 Black And White
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color. — Wikipedia, the free encyclopedia In this problem, you have to solve the 4-color problem. Hey, I’m just joking. You are asked to solve a similar problem: Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells. Matt hopes you can tell him a possible coloring.
Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases. For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ). The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used. It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells. If there are multiple solutions, output any of them.
Sample Input
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
Sample Output
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
題意:給出一個n*m的棋盤,再給你k種顏色,每種顏色給你c個,這些顏色一共可以用n*m次,現在開始使用這些顏色將棋盤塗色相鄰的棋盤不能塗相同的顏色,並且要把顏色用完,不行就輸出NO,可以的話輸出YES和輸出這個圖
我看了下部落格是dfs+剪枝,後來自己寫了下過了,還好不是很難想。
剪枝主要就是每次看下剩下的格子的一半有沒有顏色中的一個多,因為是不能相鄰塗相同顏色,那麼剩下格子數的一半cnt與剩下的每種顏色對比,如果剩下一種顏色的個數大於cnt,那麼就一定塗不完。
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int c[50],mapp[50][50];
int flag,n,m,k;
void dfs(int x,int y,int cnt)
{
if(cnt==0)
{
flag=1;
return ;
}
if(flag)
return ;
for(int i=1;i<=k;i++)//剪枝
{
if((cnt+1)/2<c[i]) return ;
}
int xx,yy;
for(int i=1;i<=k;i++)
{
if(c[i]&&mapp[x-1][y]!=i&&mapp[x][y-1]!=i)
{
mapp[x][y]=i;
c[i]--;
if(y+1>m)
yy=1,xx=x+1;
else yy=y+1,xx=x;
dfs(xx,yy,cnt-1);
if(flag)
return ;
mapp[x][y]=0;
c[i]++;
}
}
}
int main()
{
int t,casee=0;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&m,&k);
for(int i=1;i<=k;i++)
scanf("%d",&c[i]);
memset(mapp,0,sizeof(mapp));
// printf("%d\n",n*m);
flag=0;
dfs(1,1,n*m);
printf("Case #%d:\n",++casee);
if(flag==0)
printf("NO\n");
else
{
printf("YES\n");
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
if(j!=1)
printf(" ");
printf("%d",mapp[i][j]);
}
printf("\n");
}
}
}
}