1. 程式人生 > >Hdoj 1050.Moving Tables 題解

Hdoj 1050.Moving Tables 題解

rem fig system hose compute with win test data

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
技術分享圖片
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

技術分享圖片
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source

Asia 2001, Taejon (South Korea)


思路

兩個思路:

  • 把移動的房間號\(l,r\)看成平面上的一條線段,要找的就是最大重疊次數,此處剛好範圍也比較小,所以可以用這個方法
  • 貪心的思想,有點像Hdoj 2037.今年暑假不AC
    (https://www.cnblogs.com/MartinLwx/p/9727939.html)這道題目,具體思路可以看這個

代碼(思路一)

#include<bits/stdc++.h>
using namespace std;
int a[210];
int cor(int x)
{
    return x%2==0 ? x/2 : (x+1)/2;
}//返回走廊位置 
int main()
{
    int t;
    while(cin>>t)
    {
        for(int i=1;i<=t;i++)
        {
            int n;
            cin >> n;
            int l,r;
            memset(a,0,sizeof(a));
            for(int j=1;j<=n;j++)
            {
                scanf("%d%d",&l,&r);
                if(l>r)
                {
                    int t;
                    t = l; l = r; r = t;
                }
                int corl = cor(l);
                int corr = cor(r); 
                for(int k=corl;k<=corr;k++)
                    a[k]++;
            }
            //for(int j=1;j<=30;j++)    cout<<a[j]<<" ";
            int max_value = -1;
            for(int j=1;j<=201;j++)
                if(a[j]>max_value)
                    max_value = a[j];
            
            if(max_value==0)
                cout << 10 << endl;
            else
                cout << max_value*10 << endl;
        }
    }
    return 0;   
}

Hdoj 1050.Moving Tables 題解