解題報告 之 POJ 2096 Collecting Bugs
阿新 • • 發佈:2018-10-31
解題報告 之 POJ 2096 Collecting Bugs
Description
Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan's work) required to name the program disgusting.
Input
Output
Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.Sample Input
1 2
Sample Output
3.0000
Source
Northeastern Europe 2004, Northern Subregion題目大意:每天發現一個bug,這個bug發生在某一個模組,屬於一個種類;且等可能發生在每個模組,等可能發生在每個種類。問要至少要發現發生在所有模組和所有種類的bugs所需要天數的期望。
分析:一道典型的概率dp,是二維棋盤可覆蓋模型。我們把種類想成棋盤的行,把模組想成列,則問題轉化為,每天隨機指定一個格子,問至少要指到所有行和列所需要的天數期望。
我們用dp[i][j]表示已經覆蓋 i 行,j 列(具體是哪些行列不重要)所需要的天數期望。那麼明顯dp[i][j]可以轉化到四種狀態。 下一次操作: 1.沒有覆蓋到新的行和新的列。 --> i/n * j/s 2.覆蓋到新行,不覆蓋新列。 --> (n-i)/n * j/s 3.不覆蓋新行,但覆蓋了新列。 --> i/n * (s-j)/s 4.既覆蓋了新行,也覆蓋了新列。--> (n-i)/n * (s-j)/s 那麼dp[i][j]就等於這四種狀態所需要天數的加權期望+1天。
移項化簡後轉移方程為: dp[i][j] = (1.0*(n - i)*j*dp[i + 1][j] + 1.0*i*(s - j)*dp[i][j + 1] + 1.0*(n - i)*(s - j)*dp[i + 1][j + 1] + n*s) / (double)(n*s - i*j);
注意這道題的特點是選過的點可以重複選,如果不能重複選則涉及到概率的動態變化,可以參考另一篇博文。
(http://blog.csdn.net/maxichu/article/details/48886005)
上程式碼:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAXN = 1e4 + 10;
double dp[MAXN][MAXN];
int main()
{
int n, s;
while(scanf( "%d%d", &n, &s ) == 2)
{
dp[n][s] = 0.0;
for(int i = n; i >=0; i--)
{
for(int j = s; j >= 0; j--)
{
if(i == n&&j == s) continue; //注意這個格子不能更新,否則會出現錯誤
dp[i][j] = (1.0*(n - i)*j*dp[i + 1][j] + 1.0*i*(s - j)*dp[i][j + 1] + 1.0*(n - i)*(s - j)*dp[i + 1][j + 1] + n*s) / (double)(n*s - i*j);
}
}
printf( "%.4lf\n", dp[0][0] );
}
return 0;
}