1. 程式人生 > >Cooking Competition(POJ)

Cooking Competition(POJ)

                                            Cooking Competition

"Miss Kobayashi's Dragon Maid" is a Japanese manga series written and illustrated by Coolkyoushinja. An anime television series produced by Kyoto Animation aired in Japan between January and April 2017.

In episode 8, two main characters, Kobayashi and Tohru, challenged each other to a cook-off to decide who would make a lunchbox for Kanna's field trip. In order to decide who is the winner, they asked n people to taste their food, and changed their scores according to the feedback given by those people.

There are only four types of feedback. The types of feedback and the changes of score are given in the following table.

Type Feedback Score Change
(Kobayashi)
Score Change
(Tohru)
1 Kobayashi cooks better +1 0
2 Tohru cooks better 0 +1
3 Both of them are good at cooking +1 +1
4 Both of them are bad at cooking -1 -1

Given the types of the feedback of these n people, can you find out the winner of the cooking competition (given that the initial score of Kobayashi and Tohru are both 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases. For each test case:

The first line contains an integer n (1 ≤ n ≤ 20), its meaning is shown above.

The next line contains n integers a1, a2, ... , an (1 ≤ ai ≤ 4), indicating the types of the feedback given by these n people.

Output

For each test case output one line. If Kobayashi gets a higher score, output "Kobayashi" (without the quotes). If Tohru gets a higher score, output "Tohru" (without the quotes). If Kobayashi's score is equal to that of Tohru's, output "Draw" (without the quotes).

Sample Input

2
3
1 2 1
2
3 4

Sample Output

Kobayashi
Draw

Hint

For the first test case, Kobayashi gets 1 + 0 + 1 = 2 points, while Tohru gets 0 + 1 + 0 = 1 point. So the winner is Kobayashi.

For the second test case, Kobayashi gets 1 - 1 = 0 point, while Tohru gets 1 - 1 = 0 point. So it's a draw.

題目連結:

https://vjudge.net/problem/ZOJ-3958

題意描述:

有兩個人初始數值為0,四種操作,當操作是1的時候第一個人數值加1,當操作是2的時候第二個人的數值加1,當操作是3的時候兩個人的數值都加1,當操作是4的時候兩個人的數值都減1,最後輸出數值最大的人的名字,如果兩個人的數值相等輸出"Draw"

解題思路:

定義兩個變數,分別儲存兩個人的數值,最後進行比較

程式程式碼:

#include<stdio.h>

int main()
{
	int a,b,i,T,n,s;
	
	scanf("%d",&T);
	while(T--)
	{
		a=0;
		b=0;
		scanf("%d",&n);
		while(n--)
		{
			scanf("%d",&s);
			if(s==1)
				a++;
			else if(s==2)
				 b++;
			else if(s==3)
			{
				a++;
				b++;
			}
			else
			{
				a--;
				b--;
			}	
		}
		if(a>b)
			printf("Kobayashi\n");
		else if(a<b)
			printf("Tohru\n");
		else
			printf("Draw\n");
			
	}
    return 0;
}