1. 程式人生 > >shift dote ---向量的計算--Java

shift dote ---向量的計算--Java

Problem Description

給出平面直角座標系中的一點,並順序給出n個向量,求該點根據給定的n個向量位移後的位置。

Input

多組輸入,第一行是三個整數x,y,n,表示點的座標(x,y),和向量的個數n。接下來n行,每行兩個數xi,yi,表示第i個向量。題目中所有資料不會超出整形範圍。
Output

每組輸入輸出一行,"(x,y)"表示點的最終位置。
Sample Input

0 0 1
2 3
0 0 2
1 2
2 3
Sample Output

(2,3)
(3,5)

import java.util.Scanner;



public class Main
{
	public static void main(String[] args)
	{
		Scanner reader=new Scanner(System.in);
		while(reader.hasNext())
		{
			int x=reader.nextInt();
			int y=reader.nextInt();
			int n=reader.nextInt();
			for(int i=1;i<=n;i++)
			{
				x=x+reader.nextInt();
				y=y+reader.nextInt();
			}
			System.out.println("("+x+","+y+")");
		}
		reader.close();
	}
}