1. 程式人生 > >HDU2057-A + B Again

HDU2057-A + B Again

HDU2057-A + B Again

題目:
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
Sample Output
0
2C
11
-2C
-90

#include<bits/stdc++.h>
using namespace std;

int main()
{
    long long a,b;
    while(~scanf("%llX%llX",&a,&b))
    {
        if(a + b < 0)
        {
            a = -a;
            b = -b;
            cout << "-";
        }
        printf("%llX\n",a + b);
    }
    return 0;
}

需要注意的是如果用long long,輸入和輸入時都需要寫成 %llX ,%x和%X分別對應十六進位制中字母小寫和字母大寫

另外如果相加出現負數的時候需要在前面手動加“-”,然後把a,b分別取反,如果不加就會跳出一堆數字。。。。