L - One-Dimensional Maze
BaoBao is trapped in a one-dimensional maze consisting of grids arranged in a row! The grids are numbered from 1 to from left to right, and the -th grid is marked with a character , where is either 'L' or 'R'.
Starting from the -th grid, BaoBao will repeatedly take the following steps until he escapes the maze:
- If BaoBao is in the 1st grid or the -th grid, then BaoBao is considered to arrive at the exit and thus can escape successfully.
- Otherwise, let BaoBao be in the -th grid. If , BaoBao will move to the -th grid; If , Baobao will move to the -th grid.
Before taking the above steps, BaoBao can change the characters in some grids to help himself escape. Concretely speaking, for the -th grid, BaoBao can change from 'L' to 'R', or from 'R' to 'L'.
But changing characters in grids is a tiring job. Your task is to help BaoBao calculate the minimum number of grids he has to change to escape the maze.
Input
There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:
The first line contains two integers and (, ), indicating the number of grids in the maze, and the index of the starting grid.
The second line contains a string () consisting of characters 'L' and 'R'. The -th character of indicates the character in the -th grid.
It is guaranteed that the sum of over all test cases will not exceed .
Output
For each test case output one line containing one integer, indicating the minimum number of grids BaoBao has to change to escape the maze.
Sample Input
3 3 2 LRL 10 4 RRRRRRRLLR 7 4 RLLRLLR
Sample Output
0 2 1
Hint
For the first sample test case, BaoBao doesn't have to change any character and can escape from the 3rd grid. So the answer is 0.
For the second sample test case, BaoBao can change to 'R' and to 'R' and escape from the 10th grid. So the answer is 2.
For the third sample test case, BaoBao can change to 'L' and escape from the 1st grid. So the answer is 1.
#include <iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
const int N=1e5+10;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
char s[N];
scanf("%s",s);
int l,r;
l=r=0;
for(int i=m; i<n-1; i++)
{
if(s[i]=='L')
l++;
}
for(int i=1; i<m-1; i++)
{
if(s[i]=='R')
r++;
}
if(s[m-1]=='L')
l++;
else r++;
printf("%d\n",min(l,r));
}
return 0;
}