1. 程式人生 > >Wireless Network (並查集)

Wireless Network (並查集)


    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
    1. "O p" (1 <= p <= N), which means repairing computer p.
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

    The input will not exceed 300000 lines.
Output
    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4

Sample Output

    FAIL
    SUCCESS


題意:因為地震,所有電腦都損壞,給出n個電腦的位置座標,然後說明只有在有限距離內兩臺電腦才能相互連線,一系列操作之後,有多次詢問。
操作包括兩種: 1.成功修復一臺電腦。O +序號。
2.詢問x和y電腦是否相連。 S x y。

#include<stdio.h>
#include<string.h>
#include<math.h>

int f[1010],n;
int getf(int v)
{
	if(f[v] == v)
		return v;
	else
	{
		f[v] = getf(f[v]);
		return f[v];
	}
}
void merge(int v, int u)
{
	int t1,t2;
	t1 = getf(v);
	t2 = getf(u);
	if(t1 != t2)
		f[t2] = t1;
	return ;
}
int main()
{
	int i,ai,bi;
	double d,x[1010],y[1010];
	char s;
	scanf("%d%lf",&n,&d);
	memset(f,0,sizeof(f));
	for(i = 1; i <= n; i ++)
		scanf("%lf%lf",&x[i],&y[i]);
	getchar();
	while(scanf("%c",&s) != EOF)
	{
		if(s == 'O')
		{
			scanf("%d",&ai);
			f[ai] = ai;
			for(i = 1; i <= n; i ++)
			{
				if(f[i] != 0 && f[ai] != 0)
				{
					if(sqrt((x[i]-x[ai])*(x[i]-x[ai]) + (y[i]-y[ai])*(y[i]-y[ai])) <= d)
						merge(i,ai);
				}
			}
		}
		else if(s == 'S')
		{
			scanf("%d%d",&ai,&bi);
			if(ai != 0 && bi != 0)
			{
				if(getf(ai) == getf(bi))
					printf("SUCCESS\n");
				else
					printf("FAIL\n");
			}
			else
				printf("FAIL\n");
		}	
	}
	return 0;	
}