並查集------F - True Liars
After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell.
In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie.
He asked some of them whether or not some are divine. They knew one another very much and always responded to him “faithfully” according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia.
You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries.
Input
The input consists of multiple data sets, each in the following format :
n p1 p2
xl yl a1
x2 y2 a2
…
xi yi ai
…
xn yn an
The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since “are you a member of the divine tribe?” is a valid question. Note also that two lines may have the same x’s and y’s since Akira was very upset and might have asked the same question to the same one more than once.
You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.
Output
For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.
Sample Input
2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0
Sample Output
no
no
1
2
end
3
4
5
6
end
轉載:https://blog.csdn.net/acm_cxlove/article/details/8092799
又是一道帶權並查集/種類並查集的題,不知道怎麼做,還要加dp。。。。。
那麼如果一個人說另一個人是好人,那麼如果這個人是好人,說明 對方確實是好人,如果這個是壞人,說明這句話是假的,對方也是壞人。
如果一個人說另一個人是壞人,那麼如果這個人是好人,說明對方是壞人,如果這個是壞人,說明 對方是好人。
也就是如果條件是yes說明這兩個是相同集合的,否則是兩個不同的集合。
用r[i]表示i結點與根結點的關係,0為相同集合,1為不同集合。這是一個經典的並查集問題。
然後需要判斷是否唯一
我們通過並查集,可以將所有人分為若干個集合,其中對於每一個集合,又分為兩個集合(好人和壞人,但是不知道哪些是好人,哪些是壞人,我們只有相對關係)
接下來就是從所有大集合中的兩個小集合取一個,組成好人集合,判斷是否唯一。
這個就是用dp:
揹包問題,dp[i][j]表示前i個大集合,好人為j個的方案有多少種;
如果dp[cnt][p1] != 1,說明最後結果無解或者無唯一解
剩下輸出路徑時逆推結果
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
const double eps = 1e-8;
const double PI = acos(-1);
#define pb push_back
#define mp make_pair
#define fi first
#define se second
const int N = 605;
const int MAXN = 1005;
bool vis[N];
int dp[N][N / 2];
int res[N][2];
vector<int>ve[N][2];
vector<int>ans;
int b[N];
int r[N];
int n,p1,p2;
int join(int x)
{
int k = b[x];
if(b[x] != x){
b[x] = join(b[x]);
r[x] = (r[x] + r[k]) % 2;
}
return b[x];
}
int main()
{
while(~scanf("%d %d %d",&n,&p1,&p2))
{
if(n == 0 && p1 == 0 && p2 == 0){
break;
}
ans.clear();
for(int i = 0;i < N;++i){
ve[i][0].clear();
ve[i][1].clear();
}
for(int i = 1;i <= p1 + p2;++i){
b[i] = i;
r[i] = 0;
}
for(int i = 0;i < n;++i){
int x,y;
char ch[5];
scanf("%d %d %s",&x,&y,ch);
int k = (ch[0] == 'n');
int tx = join(x),ty = join(y);
if(tx != ty){
b[tx] = ty;
r[tx] = (r[y] - r[x] + k + 2) % 2;
}
}
memset(vis,false,sizeof(vis));
memset(res,0,sizeof(res));
int cnt = 1;
for(int i = 1;i <= p1 + p2;++i){
if(!vis[i]){
int x = join(i);
for(int j = i;j <= p1 + p2;++j){
if(join(j) == x){
vis[j] = true;
ve[cnt][r[j]].pb(j);
res[cnt][r[j]]++;
}
}
cnt++;
}
}
memset(dp,0,sizeof(dp));
dp[0][0] = 1;
for(int i = 1;i < cnt;++i){
for(int j = p1;j >= 0;--j){
if(j - res[i][0] >= 0){
dp[i][j] += dp[i - 1][j - res[i][0]];
}
if(j - res[i][1] >= 0){
dp[i][j] += dp[i - 1][j - res[i][1]];
}
}
}
if(dp[cnt - 1][p1] != 1){
printf("no\n");
}else{
for(int i = cnt - 1;i >= 1;--i){
if(p1 - res[i][0] >= 0 && p2 - res[i][1] >= 0 && dp[i - 1][p1 - res[i][0]] == 1){
for(int j = 0;j < ve[i][0].size();++j){
ans.pb(ve[i][0][j]);
}
p1 -= res[i][0];
p2 -= res[i][1];
}else if(p1 - res[i][1] >= 0 && p2 - res[i][0] >= 0 && dp[i - 1][p1 - res[i][1]] == 1){
for(int j = 0;j < ve[i][1].size();++j){
ans.pb(ve[i][1][j]);
}
p1 -= res[i][1];
p2 -= res[i][0];
}
}
sort(ans.begin(),ans.end());
int len = ans.size();
for(int i = 0;i < len;++i){
printf("%d\n",ans[i]);
}
printf("end\n");
}
}
return 0;
}