FZU2150 Fire Game【BFS+暴力】
Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)
You can assume that the grass in the board would never burn out and the empty grid would never get fire.
Note that the two grids they choose can be the same.
Input
The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.
1 <= T <=100, 1 <= n <=10, 1 <= m <=10
Output
For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.
Sample Input
4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#
Sample Output
Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2
問題描述:兩個熊孩子在n*m的平地上放火玩,#表示草,兩個熊孩子分別選一個#格子點火,火可以向上向下向左向右在有草的格子蔓延,點火的地方時間為0,蔓延至下一格的時間依次加一。求燒完所有的草需要的最少時間。如不能燒完輸出-1。
題解:BFS+暴力,依次列舉兩個#格子,BFS出需要的時間,取最小的一個。
C++程式:
#include<iostream>
#include<queue>
#include<utility>
#include<cstring>
using namespace std;
const int N=15;
int d[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
char g[N][N];
char vis[N][N];
int n,m,total;
struct Node{
int x,y,t;
Node(int x,int y,int t):x(x),y(y),t(t){}
};
queue<Node>q;
int bfs()
{
int num=total;
while(!q.empty()){
Node f=q.front();
q.pop();
num--;//草地個數減一
if(num==0)
return f.t;//返回最後一個草地被燒掉的時間
for(int i=0;i<4;i++){
int fx=f.x+d[i][0];
int fy=f.y+d[i][1];
if(0<=fx&&fx<=n&&0<=fy&&fy<=n&&vis[fx][fy]=='#'){
vis[fx][fy]='.';
q.push(Node(fx,fy,f.t+1));
}
}
}
return -1;//不成功
}
int main()
{
int T;
scanf("%d",&T);
for(int t=1;t<=T;t++){
vector<pair<int,int> >v;//儲存草地的位置
total=0;//統計草地個數
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
for(int j=0;j<m;j++){
scanf(" %c",&g[i][j]);
if(g[i][j]=='#')
v.push_back(make_pair(i,j));
}
total=v.size();
printf("Case %d: ",t);
if(total==0||total==1){
printf("0\n");
continue;
}
int ans=-1,time;
for(int i=0;i<v.size();i++)
for(int j=i+1;j<v.size();j++){
memcpy(vis,g,sizeof(g));
int x1=v[i].first,y1=v[i].second,x2=v[j].first,y2=v[j].second;
vis[x1][y1]='.';
vis[x2][y2]='.';
while(!q.empty()) q.pop();//清空佇列
q.push(Node(x1,y1,0));
q.push(Node(x2,y2,0));
time=bfs();
if(time>=0&&(ans==-1||ans>time))
ans=time;
}
if(ans==-1)
printf("-1\n");
else
printf("%d\n",ans);
}
return 0;
}