zcmu 1121: 取石子游戲I
阿新 • • 發佈:2018-11-14
1121: 取石子游戲I
Time Limit: 1 Sec Memory Limit: 128 MB
Description
一堆石子有n個,兩人輪流取.先取者第1次可以取任意多個,但不能全部取完.以後每次取的石子數不能超過上次取子數的2倍。取完者勝.先取者負輸出"Second win".先取者勝輸出"First win".
Input
多組測試資料。
每組測試資料包含1個整數n。(1<n<=1000000000)
Output
對於每組測試資料,輸出誰獲勝.
Sample Input
2
13
10000
Sample Output
Second win
Second win
First win
HINT
Source
【分析】
經典的斐波那契博弈題,大家可以瞭解一下,在斐波那契博弈中先手必敗數為斐波那契數
//斐波那契博弈的要求就是題目的要求了
【程式碼】
#include <iostream>
#include <set>
#include <bits/stdc++.h>
using namespace std;
set<double>a;
set<double>::iterator x;
int main()
{
double n=1,m=1,k;
for(int i=0; i<=50; i++)
{
k=m+n;
a.insert(k);
n=m;
m=k;
}
while(scanf("%lf",&n)!=EOF)
{
x=a.find(n);
if(x!=a.end())
printf("Second win\n");
else
printf("First win\n");
}
return 0;
}