sincerit 1527 取石子游戲(威佐夫博弈)
阿新 • • 發佈:2018-12-18
取石子游戲 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9962 Accepted Submission(s): 5748 Problem Description 有兩堆石子,數量任意,可以不同。遊戲開始由兩個人輪流取石子。遊戲規定,每次有兩種不同的取法,一是可以在任意的一堆中取走任意多的石子;二是可以在兩堆中同時取走相同數量的石子。最後把石子全部取完者為勝者。現在給出初始的兩堆石子的數目,如果輪到你先取,假設雙方都採取最好的策略,問最後你是勝者還是敗者。
Input 輸入包含若干行,表示若干種石子的初始情況,其中每一行包含兩個非負整數a和b,表示兩堆石子的數目,a和b都不大於1,000,000,000。 Output 輸出對應也有若干行,每行包含一個數字1或0,如果最後你是勝者,則為1,反之,則為0。 Sample Input 2 1 8 4 4 7 Sample Output 0 1 0
#include <stdio.h>
#include <math.h>
void swap(int* a, int* b) {
int t = *a;
*a = *b;
*b = t;
}
int main() {
int n, m;
while (~scanf("%d%d", &n, &m)) {
double w = (sqrt(5.0) + 1) / 2;
if (n > m) swap(&n, &m);
int temp = int(w * (m - n));
if (temp == n) printf("0\n");
else printf("1\n");
}
return 0;
}