1. 程式人生 > >UVA 796-Critical Links (求橋)

UVA 796-Critical Links (求橋)

In a computer network a link L, which interconnects two servers, is considered critical if there are at least two servers A and B such that all network interconnection paths between A and B pass through L. Removing a critical link generates two disjoint sub–networks such that any two servers of a sub–network are interconnected. For example, the network shown in figure 1 has three critical links that are marked bold: 0 -1, 3 - 4 and 6 - 7.
Figure 1: Critical links
It is known that:
1. the connection links are bi–directional;
2. a server is not directly connected to itself;
3. two servers are interconnected if they are directly connected or if they are interconnected with the same server;
4. the network can have stand–alone sub–networks.
Write a program that finds all critical links of a given computer network.
Input
The program reads sets of data from a text file. Each data set specifies the structure of a network and has the format:
no of servers server0 (no of direct connections) connected server ... connected server ... serverno of servers (no of direct connections) connected server ... connected server
The first line contains a positive integer no of servers(possibly 0) which is the number of network servers. The next no of servers lines, one for each server in the network, are randomly ordered and show the way servers are connected. The line corresponding to serverk, 0 ≤ k ≤ no of servers−1, specifies the number of direct connections of serverk and the servers which are directly connected to serverk. Servers are represented by integers from 0 to no of servers−1. Input data are correct. The first data set from sample input below corresponds to the network in figure 1, while the second data set specifies an empty network.
Output
The result of the program is on standard output. For each data set the program prints the number of critical links and the critical links, one link per line, starting from the beginning of the line, as shown in the sample output below. The links are listed in ascending order according to their first element. The output for the data set is followed by an empty line.
Sample Input
8

0 (1) 1

1 (3) 2 0 3

2 (2) 1 3

3 (3) 1 2 4

4 (1) 3

7 (1) 6

6 (1) 7

5 (0)
0
Sample Output
3 critical links

0 - 1

3 - 4

6 - 7
0 critical links

思路:tarjan求橋(割邊)模板題。跑一遍tarjan演算法,如果LOW[v]>DFN[u]說明子節點無法通過父親節點以外的節點回溯到父親節點,則(u,v)為橋(割邊)。

#include<string.h>
#include<algorithm>
#include<stdio.h>
#include<stack>
#define M 110
using namespace std;
struct path
{
    int to,nextt;
}A[M*M];
struct node
{
    int x,y;
}ans[M*M];
stack<int>q;
int n,x,y,m,sum;
int DFN[M],LOW[M],book[M],indox,carry,v;
int head[M],tot;
void init()
{
    tot=indox=carry=sum=0;
    memset(head,-1,sizeof(head));
    memset(DFN,-1,sizeof(DFN));
    memset(LOW,-1,sizeof(LOW));
}
void add(int from,int to)
{
    ++tot;
    A[tot].to=to;
    A[tot].nextt=head[from];
    head[from]=tot;
}
void tarjan(int u,int pre)
{
    q.push(u);
    DFN[u]=LOW[u]=++indox;
    book[u]=1;
    for(int i=head[u];i!=-1;i=A[i].nextt)
    {
        int tem=A[i].to;
        if(tem==pre) continue;
        if(DFN[tem]==-1)
        {
            tarjan(tem,u);
            LOW[u]=min(LOW[u],LOW[tem]);
        }
        else if(book[tem])
        {
            LOW[u]=min(LOW[u],DFN[tem]);
        }
    }
    if(DFN[u]==LOW[u])
    {
        ++carry;
        do
        {
            v=q.top();
            q.pop();
            book[v]=0;
        }while(v!=u);
    }
}
int cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1;i<=n;i++)
        {
            scanf("%d (%d)",&x,&m);
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&y);
                add(x,y);
            }
        }
        for(int i=0;i<n;i++)
        {
            if(DFN[i]==-1)
                tarjan(i,i);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=head[i];j!=-1;j=A[j].nextt)
            {
                v=A[j].to;
                if(LOW[v]>DFN[i])
                {
                    ans[sum].x=min(i,v);
                    ans[sum].y=max(i,v);
                    sum++;
                }
            }
        }
        sort(ans,ans+sum,cmp);
        printf("%d critical links\n",sum);
        for(int i=0;i<sum;i++)
        {
            printf("%d - %d\n",ans[i].x,ans[i].y);
        }
        printf("\n");
    }
}