1. 程式人生 > >Spreading the Wealth( UVA - 11300)

Spreading the Wealth( UVA - 11300)

題目連結: Spreading the Wealth

 UVA - 11300 

Problem


A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input


There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output


For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input


3
100
100
100
4
1
2
5
4


Sample Output


0
4
解題思路:這個題目一看到題目感覺不是很複雜,覺得其中應該有一定的數學關係,但是推了一會並沒有得出答案,只想到了一個距離的關係。書上這個題目給出的方法十分的好,之前也沒有見過這個方法。 
假設對所有的人進行從1到n進行編號,第1個人給第n個人x1枚金幣,給第2個人x2金幣,第二個人給第一個人-x2枚金幣,給第三個人x3枚金幣…….. 
從這個方面我們可以得到一個公式 
A1 - x1 + x2 = M -> x2 = M - A1 + x2 = x1 - C1(規定C1 = A1 - M) 
A2 - x2 + x3 = M -> x3 = M - A2 + x2 = 2M - A1 - A2 + x1 = x1 - C2 
…… 
所有的交換金幣次數為x1到xn的絕對值的和 
找到中位數即可求的最小值

程式碼如下:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<math.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll arr[1000000],brr[1000000];
int main()
{
    ll n;
    while (cin >> n)
    {
        ll sum = 0;
        for (int i = 1; i <= n; ++i)
        {
            cin >> arr[i];
            sum += arr[i];
        }
        ll num = sum / n;
        brr[0] = 0;
        for (int i = 1; i < n; ++i)
        {
            brr[i] = brr[i - 1] + arr[i] - num;
        }
        sort(brr, brr + n);
        ll x1 = brr[n / 2];
        ll ans = 0;
        for (int i = 0; i < n; ++i)
            ans += abs(x1 - brr[i]);
        cout << ans << endl;
    }
    return 0;
}